Deal with `pidof browser-switchboard` returning no pids
[browser-switch] / debian / rules
index 82a69bf..962a2e3 100755 (executable)
@@ -22,6 +22,9 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
+       make
+       make -C config-ui
+
        touch $@
 
 clean:
@@ -29,6 +32,9 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
+       make clean
+       make -C config-ui clean
+
        dh_clean 
 
 install: build
@@ -37,13 +43,16 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/browser-proxy.
-       install -c -m 0755 browser-proxy debian/browser-proxy/usr/bin/browser-proxy
-       install -c -m 0644 com.nokia.osso_browser.service debian/browser-proxy/usr/share/dbus-1/services
-       install -c -m 0755 browser debian/browser-proxy/usr/bin/browser
+       # Add here commands to install the package into
+       # debian/browser-switchboard.
+       make DESTDIR=debian/browser-switchboard install
+       make -C config-ui DESTDIR=../debian/browser-switchboard install
 
 
 binary-indep: build install
+# arch: any package, nothing to do here
+
+binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
@@ -62,19 +71,16 @@ binary-indep: build install
 #      dh_installinfo
 #      dh_installman
 #      dh_link
-#      dh_strip
+       dh_strip
        dh_compress
        dh_fixperms
 #      dh_perl
 #      dh_makeshlibs
        dh_installdeb
-#      dh_shlibdeps
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary-arch: build install
-# arch: all package, nothing to do here
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure