po templates, debian/rules and install policy
[cell-modem-ui] / cell-modem-ui / debian / rules
index eec4bbb..576a029 100755 (executable)
@@ -40,10 +40,17 @@ install: build
        dh_testroot
        dh_clean -k 
        dh_installdirs
-       #mkdir -p $(CURDIR)/debian/tmp/etc/systemui
+
+       # install our xml to /opt
        mkdir -p $(CURDIR)/debian/tmp/opt/cell-modem-ui
        cp $(CURDIR)/etc/systemui/*.xml $(CURDIR)/debian/tmp/opt/cell-modem-ui/
 
+       # install our translations by hand
+       for i in fi_FI en_GB en_US es_ES fr_FR sv_SE pl_PL nl_NL it_IT de_DE; do
+               mkdir -p $(CURDIR)/debian/tmp/usr/share/locale/$i/LC_MESSAGES
+               msgfmt $(CURDIR)/po/$i.po -o $(CURDIR)/debian/tmp/usr/share/locale/$i/LC_MESSAGES/cell-modem-ui.mo
+       done
+
 binary-indep: build install
 
 binary-arch: build install