debian-related files, installation
[colorflood] / colorflood / src / CMakeLists.txt
index 181f65e..0fd71ef 100644 (file)
@@ -10,6 +10,7 @@
 # GNU General Public License for more details.
 
 set(src
+  colorbutton.cpp
   colorbuttons.cpp
   colorscheme.cpp
   field.cpp
@@ -19,6 +20,7 @@ set(src
   )
 
 set(moc
+  colorbutton.hpp
   colorbuttons.hpp
   field.hpp
   fullscreenexitbutton.hpp
@@ -36,3 +38,7 @@ qt4_add_resources(resources colorflood.qrc)
 add_definitions(-Wall -Wextra)
 add_executable(colorflood ${moc_src} ${src} ${res})
 target_link_libraries(colorflood ${QT_LIBRARIES})
+
+install(TARGETS colorflood DESTINATION bin)
+install(FILES images/icon_48x48.png DESTINATION share/icons/hicolor/48x48/apps RENAME colorflood.png)
+install(FILES colorflood.desktop DESTINATION share/applications/hildon)