update version
[colorflood] / colorflood / src / CMakeLists.txt
index a73889e..0fd71ef 100644 (file)
@@ -23,7 +23,7 @@ set(moc
   colorbutton.hpp
   colorbuttons.hpp
   field.hpp
-  #fullscreenexitbutton.hpp
+  fullscreenexitbutton.hpp
   window.hpp
   )
 
@@ -38,3 +38,7 @@ qt4_add_resources(resources colorflood.qrc)
 add_definitions(-Wall -Wextra)
 add_executable(colorflood ${moc_src} ${src} ${res})
 target_link_libraries(colorflood ${QT_LIBRARIES})
+
+install(TARGETS colorflood DESTINATION bin)
+install(FILES images/icon_48x48.png DESTINATION share/icons/hicolor/48x48/apps RENAME colorflood.png)
+install(FILES colorflood.desktop DESTINATION share/applications/hildon)