Add skeleton for service interface includes
[connman] / include / Makefile.am
index 704ac56..25f9b30 100644 (file)
@@ -1,15 +1,24 @@
 
 includedir = @includedir@/connman
 
-include_HEADERS = log.h plugin.h security.h resolver.h driver.h \
-                               element.h property.h network.h rtnl.h dbus.h
+include_HEADERS = types.h log.h plugin.h security.h resolver.h \
+                               storage.h device.h network.h notifier.h
 
-noinst_HEADERS = device.h
+nodist_include_HEADERS = version.h
+
+noinst_HEADERS = driver.h element.h property.h ipv4.h rtnl.h dbus.h \
+                                                               service.h
 
 MAINTAINERCLEANFILES = Makefile.in
 
 all-local:
-       @if [ ! -e connman ] ; then $(LN_S) $(top_srcdir)/include connman ; fi
+       @if [ ! -e connman ]; then \
+         mkdir connman; \
+         list='$(include_HEADERS) $(noinst_HEADERS)'; for i in $$list; \
+           do $(LN_S) $(abs_top_srcdir)/include/$$i connman/$$i; done; \
+         list='$(nodist_include_HEADERS)'; for i in $$list; \
+           do $(LN_S) $(abs_top_builddir)/include/$$i connman/$$i; done; \
+       fi
 
 clean-local:
-       @rm -f connman
+       @rm -rf connman