Use symlinks instead of copying header files
[connman] / include / Makefile.am
index 4c10f17..f8e9e73 100644 (file)
@@ -1,12 +1,23 @@
 
 includedir = @includedir@/connman
 
-noinst_HEADERS = log.h plugin.h iface.h rtnl.h dhcp.h resolver.h
+include_HEADERS = types.h log.h plugin.h security.h resolver.h \
+                                       storage.h device.h network.h
+
+nodist_include_HEADERS = version.h
+
+noinst_HEADERS = driver.h element.h property.h ipv4.h rtnl.h dbus.h
 
 MAINTAINERCLEANFILES = Makefile.in
 
 all-local:
-       @if [ ! -e connman ] ; then $(LN_S) $(top_srcdir)/include connman ; fi
+       @if [ ! -e connman ]; then \
+         mkdir connman; \
+         list='$(include_HEADERS) $(noinst_HEADERS)'; for i in $$list; \
+           do $(LN_S) $(abs_top_srcdir)/include/$$i connman/$$i; done; \
+         list='$(nodist_include_HEADERS)'; for i in $$list; \
+           do $(LN_S) $(abs_top_builddir)/include/$$i connman/$$i; done; \
+       fi
 
 clean-local:
-       @rm -f connman
+       @rm -rf connman