Add priority field to plugin descriptor definition
[connman] / plugins / Makefile.am
index f2b280c..4c43ea5 100644 (file)
@@ -1,7 +1,7 @@
 
 plugindir = $(libdir)/connman/plugins
 
-plugin_LTLIBRARIES = ethernet.la bluetooth.la ipv4.la dnsproxy.la
+plugin_LTLIBRARIES =
 
 if LOOPBACK
 plugin_LTLIBRARIES += loopback.la
@@ -9,7 +9,11 @@ plugin_LTLIBRARIES += loopback.la
 loopback_la_SOURCES = loopback.c
 endif
 
+if ETHERNET
+plugin_LTLIBRARIES += ethernet.la
+
 ethernet_la_SOURCES = ethernet.c inet.h inet.c
+endif
 
 if WIFI
 plugin_LTLIBRARIES += wifi.la
@@ -18,8 +22,18 @@ wifi_la_SOURCES = wifi.c inet.h inet.c supplicant.h supplicant.c
 wifi_la_LIBADD = @GDBUS_LIBS@
 endif
 
+if WIMAX
+plugin_LTLIBRARIES += wimax.la
+
+wimax_la_SOURCES = wimax.c
+endif
+
+if BLUETOOTH
+plugin_LTLIBRARIES += bluetooth.la
+
 bluetooth_la_SOURCES = bluetooth.c inet.h inet.c
 bluetooth_la_LIBADD = @GDBUS_LIBS@
+endif
 
 if NOVATEL
 plugin_LTLIBRARIES += novatel.la
@@ -39,8 +53,6 @@ plugin_LTLIBRARIES += hso.la
 hso_la_SOURCES = hso.c modem.h modem.c
 endif
 
-ipv4_la_SOURCES = ipv4.c inet.h inet.c
-
 if UDHCP
 plugin_LTLIBRARIES += udhcp.la
 
@@ -64,8 +76,6 @@ pppd_la_SOURCES = pppd.c
 pppd_la_CFLAGS = @GLIB_CFLAGS@ -DPPPD=\"@PPPD@\"
 endif
 
-dnsproxy_la_SOURCES = dnsproxy.c
-
 if RESOLVCONF
 plugin_LTLIBRARIES += resolvconf.la
 
@@ -73,6 +83,12 @@ resolvconf_la_SOURCES = resolvconf.c
 resolvconf_la_CFLAGS = @GLIB_CFLAGS@ -DRESOLVCONF=\"@RESOLVCONF@\"
 endif
 
+if DNSPROXY
+plugin_LTLIBRARIES += dnsproxy.la
+
+dnsproxy_la_SOURCES = dnsproxy.c
+endif
+
 if POLKIT
 plugin_LTLIBRARIES += polkit.la
 
@@ -80,10 +96,19 @@ polkit_la_SOURCES = polkit.c
 polkit_la_LIBADD = @POLKIT_LIBS@ @GLIB_LIBS@
 polkit_la_CFLAGS = @GLIB_CFLAGS@ @POLKIT_CFLAGS@
 
-policydir = $(datadir)/PolicyKit/policy
+if DATAFILES
+policydir = @POLKIT_DATADIR@
 
 policy_DATA = connman.policy
 endif
+endif
+
+if OSPM
+plugin_LTLIBRARIES += ospm.la
+
+polkit_la_SOURCES = ospm.c
+polkit_la_CFLAGS = @GDBUS_CFLAGS@
+endif
 
 if FAKE
 plugin_LTLIBRARIES += fake.la
@@ -106,6 +131,11 @@ AM_CFLAGS = @GLIB_CFLAGS@ @GDBUS_CFLAGS@
 
 INCLUDES = -I$(top_builddir)/include
 
-EXTRA_DIST = connman.policy
+CLEANFILES = connman.policy
+
+EXTRA_DIST = polkit.policy
 
 MAINTAINERCLEANFILES = Makefile.in
+
+connman.policy: polkit.policy
+       cp $< $@