Add priority field to plugin descriptor definition
[connman] / plugins / Makefile.am
index f616c0d..4c43ea5 100644 (file)
@@ -1,40 +1,93 @@
 
 plugindir = $(libdir)/connman/plugins
 
-plugin_LTLIBRARIES = loopback.la netdev.la ethernet.la wifi.la \
-                       bluetooth.la hso.la udhcp.la dhclient.la ipv4.la \
-                               dnsproxy.la resolvconf.la resolvfile.la
+plugin_LTLIBRARIES =
+
+if LOOPBACK
+plugin_LTLIBRARIES += loopback.la
 
 loopback_la_SOURCES = loopback.c
+endif
 
-netdev_la_SOURCES = netdev.c
+if ETHERNET
+plugin_LTLIBRARIES += ethernet.la
 
 ethernet_la_SOURCES = ethernet.c inet.h inet.c
+endif
+
+if WIFI
+plugin_LTLIBRARIES += wifi.la
 
 wifi_la_SOURCES = wifi.c inet.h inet.c supplicant.h supplicant.c
 wifi_la_LIBADD = @GDBUS_LIBS@
+endif
+
+if WIMAX
+plugin_LTLIBRARIES += wimax.la
+
+wimax_la_SOURCES = wimax.c
+endif
+
+if BLUETOOTH
+plugin_LTLIBRARIES += bluetooth.la
 
-bluetooth_la_SOURCES = bluetooth.c
+bluetooth_la_SOURCES = bluetooth.c inet.h inet.c
 bluetooth_la_LIBADD = @GDBUS_LIBS@
+endif
+
+if NOVATEL
+plugin_LTLIBRARIES += novatel.la
+
+novatel_la_SOURCES = novatel.c modem.h modem.c
+endif
+
+if HUAWEI
+plugin_LTLIBRARIES += huawei.la
 
-hso_la_SOURCES = hso.c
+huawei_la_SOURCES = huawei.c modem.h modem.c
+endif
+
+if HSO
+plugin_LTLIBRARIES += hso.la
+
+hso_la_SOURCES = hso.c modem.h modem.c
+endif
+
+if UDHCP
+plugin_LTLIBRARIES += udhcp.la
 
 udhcp_la_SOURCES = udhcp.c inet.h inet.c task.h task.c
 udhcp_la_CFLAGS = @GLIB_CFLAGS@ @GDBUS_CFLAGS@ -DUDHCPC=\"@UDHCPC@\" \
                -DSTATEDIR=\""$(statedir)"\" -DSCRIPTDIR=\""$(scriptdir)"\"
+endif
+
+if DHCLIENT
+plugin_LTLIBRARIES += dhclient.la
 
 dhclient_la_SOURCES = dhclient.c inet.h inet.c
 dhclient_la_CFLAGS = @GLIB_CFLAGS@ @GDBUS_CFLAGS@ -DDHCLIENT=\"@DHCLIENT@\" \
                -DSTATEDIR=\""$(statedir)"\" -DSCRIPTDIR=\""$(scriptdir)"\"
+endif
 
-ipv4_la_SOURCES = ipv4.c
+if PPPD
+plugin_LTLIBRARIES += pppd.la
 
-dnsproxy_la_SOURCES = dnsproxy.c
+pppd_la_SOURCES = pppd.c
+pppd_la_CFLAGS = @GLIB_CFLAGS@ -DPPPD=\"@PPPD@\"
+endif
+
+if RESOLVCONF
+plugin_LTLIBRARIES += resolvconf.la
 
 resolvconf_la_SOURCES = resolvconf.c
 resolvconf_la_CFLAGS = @GLIB_CFLAGS@ -DRESOLVCONF=\"@RESOLVCONF@\"
+endif
 
-resolvfile_la_SOURCES = resolvfile.c
+if DNSPROXY
+plugin_LTLIBRARIES += dnsproxy.la
+
+dnsproxy_la_SOURCES = dnsproxy.c
+endif
 
 if POLKIT
 plugin_LTLIBRARIES += polkit.la
@@ -43,10 +96,19 @@ polkit_la_SOURCES = polkit.c
 polkit_la_LIBADD = @POLKIT_LIBS@ @GLIB_LIBS@
 polkit_la_CFLAGS = @GLIB_CFLAGS@ @POLKIT_CFLAGS@
 
-policydir = $(datadir)/PolicyKit/policy
+if DATAFILES
+policydir = @POLKIT_DATADIR@
 
 policy_DATA = connman.policy
 endif
+endif
+
+if OSPM
+plugin_LTLIBRARIES += ospm.la
+
+polkit_la_SOURCES = ospm.c
+polkit_la_CFLAGS = @GDBUS_CFLAGS@
+endif
 
 if FAKE
 plugin_LTLIBRARIES += fake.la
@@ -69,6 +131,11 @@ AM_CFLAGS = @GLIB_CFLAGS@ @GDBUS_CFLAGS@
 
 INCLUDES = -I$(top_builddir)/include
 
-EXTRA_DIST = connman.policy
+CLEANFILES = connman.policy
+
+EXTRA_DIST = polkit.policy
 
 MAINTAINERCLEANFILES = Makefile.in
+
+connman.policy: polkit.policy
+       cp $< $@