Add option for selecting Bluetooth support
[connman] / plugins / Makefile.am
index ac6714d..9b013ad 100644 (file)
@@ -1,7 +1,7 @@
 
 plugindir = $(libdir)/connman/plugins
 
-plugin_LTLIBRARIES = ethernet.la bluetooth.la ipv4.la
+plugin_LTLIBRARIES = ipv4.la
 
 if LOOPBACK
 plugin_LTLIBRARIES += loopback.la
@@ -9,7 +9,11 @@ plugin_LTLIBRARIES += loopback.la
 loopback_la_SOURCES = loopback.c
 endif
 
+if ETHERNET
+plugin_LTLIBRARIES += ethernet.la
+
 ethernet_la_SOURCES = ethernet.c inet.h inet.c
+endif
 
 if WIFI
 plugin_LTLIBRARIES += wifi.la
@@ -18,8 +22,12 @@ wifi_la_SOURCES = wifi.c inet.h inet.c supplicant.h supplicant.c
 wifi_la_LIBADD = @GDBUS_LIBS@
 endif
 
+if BLUETOOTH
+plugin_LTLIBRARIES += bluetooth.la
+
 bluetooth_la_SOURCES = bluetooth.c inet.h inet.c
 bluetooth_la_LIBADD = @GDBUS_LIBS@
+endif
 
 if NOVATEL
 plugin_LTLIBRARIES += novatel.la