Use correct flags for PPP plugin
[connman] / plugins / Makefile.am
index ef5a82d..f2b280c 100644 (file)
@@ -1,31 +1,77 @@
 
 plugindir = $(libdir)/connman/plugins
 
-plugin_LTLIBRARIES = ethernet.la wifi.la bluetooth.la \
-                               netdev.la dhclient.la ipv4.la \
-                               resolvconf.la resolvfile.la rtnllink.la
+plugin_LTLIBRARIES = ethernet.la bluetooth.la ipv4.la dnsproxy.la
 
-ethernet_la_SOURCES = ethernet.c
+if LOOPBACK
+plugin_LTLIBRARIES += loopback.la
+
+loopback_la_SOURCES = loopback.c
+endif
+
+ethernet_la_SOURCES = ethernet.c inet.h inet.c
+
+if WIFI
+plugin_LTLIBRARIES += wifi.la
 
 wifi_la_SOURCES = wifi.c inet.h inet.c supplicant.h supplicant.c
 wifi_la_LIBADD = @GDBUS_LIBS@
+endif
 
-bluetooth_la_SOURCES = bluetooth.c
+bluetooth_la_SOURCES = bluetooth.c inet.h inet.c
 bluetooth_la_LIBADD = @GDBUS_LIBS@
 
-netdev_la_SOURCES = netdev.c
+if NOVATEL
+plugin_LTLIBRARIES += novatel.la
+
+novatel_la_SOURCES = novatel.c modem.h modem.c
+endif
+
+if HUAWEI
+plugin_LTLIBRARIES += huawei.la
+
+huawei_la_SOURCES = huawei.c modem.h modem.c
+endif
+
+if HSO
+plugin_LTLIBRARIES += hso.la
+
+hso_la_SOURCES = hso.c modem.h modem.c
+endif
+
+ipv4_la_SOURCES = ipv4.c inet.h inet.c
+
+if UDHCP
+plugin_LTLIBRARIES += udhcp.la
+
+udhcp_la_SOURCES = udhcp.c inet.h inet.c task.h task.c
+udhcp_la_CFLAGS = @GLIB_CFLAGS@ @GDBUS_CFLAGS@ -DUDHCPC=\"@UDHCPC@\" \
+               -DSTATEDIR=\""$(statedir)"\" -DSCRIPTDIR=\""$(scriptdir)"\"
+endif
+
+if DHCLIENT
+plugin_LTLIBRARIES += dhclient.la
 
 dhclient_la_SOURCES = dhclient.c inet.h inet.c
 dhclient_la_CFLAGS = @GLIB_CFLAGS@ @GDBUS_CFLAGS@ -DDHCLIENT=\"@DHCLIENT@\" \
                -DSTATEDIR=\""$(statedir)"\" -DSCRIPTDIR=\""$(scriptdir)"\"
+endif
 
-ipv4_la_SOURCES = ipv4.c
+if PPPD
+plugin_LTLIBRARIES += pppd.la
 
-resolvconf_la_SOURCES = resolvconf.c inet.h inet.c
+pppd_la_SOURCES = pppd.c
+pppd_la_CFLAGS = @GLIB_CFLAGS@ -DPPPD=\"@PPPD@\"
+endif
 
-resolvfile_la_SOURCES = resolvfile.c
+dnsproxy_la_SOURCES = dnsproxy.c
 
-rtnllink_la_SOURCES = rtnllink.c inet.h inet.c
+if RESOLVCONF
+plugin_LTLIBRARIES += resolvconf.la
+
+resolvconf_la_SOURCES = resolvconf.c
+resolvconf_la_CFLAGS = @GLIB_CFLAGS@ -DRESOLVCONF=\"@RESOLVCONF@\"
+endif
 
 if POLKIT
 plugin_LTLIBRARIES += polkit.la