Remove obsolete file.
[connman] / src / Makefile.am
index 79da404..4414ec2 100644 (file)
@@ -8,9 +8,10 @@ endif
 sbin_PROGRAMS = connmand
 
 connmand_SOURCES = main.c connman.h log.c selftest.c error.c plugin.c \
-                       profile.c element.c device.c network.c connection.c \
-                       security.c resolver.c storage.c manager.c agent.c \
-                       ipv4.c detect.c rtnl.c dbus.c
+                       element.c device.c network.c connection.c \
+                       manager.c profile.c service.c agent.c notifier.c \
+                       security.c resolver.c ipconfig.c rfkill.c \
+                       storage.c ipv4.c detect.c rtnl.c inet.c dbus.c
 
 if UDEV
 connmand_SOURCES += udev.c
@@ -22,11 +23,12 @@ rules_DATA = 92-connman.rules
 endif
 endif
 
-connmand_LDADD = @GDBUS_LIBS@ @GLIB_LIBS@ @GTHREAD_LIBS@ @UDEV_LIBS@ -ldl
+connmand_LDADD = $(top_builddir)/plugins/libbuiltin.la \
+               @GDBUS_LIBS@ @GLIB_LIBS@ @GTHREAD_LIBS@ @UDEV_LIBS@ -ldl
 
 connmand_LDFLAGS = -Wl,--export-dynamic -Wl,--version-script=connman.ver
 
-connmand_DEPENDENCIES = connman.ver
+connmand_DEPENDENCIES = connman.ver $(top_builddir)/plugins/libbuiltin.la
 
 CLEANFILES = connman.ver connman.exp connman.conf 92-connman.rules
 
@@ -45,7 +47,7 @@ AM_CFLAGS = @UDEV_CFLAGS@ @GTHREAD_CFLAGS@ @GLIB_CFLAGS@ @GDBUS_CFLAGS@ \
                                        -DPLUGINDIR=\""$(plugindir)"\" \
                                        -DSTORAGEDIR=\""$(storagedir)\""
 
-INCLUDES = -I$(top_builddir)/include
+INCLUDES = -I$(top_builddir)/include -I$(top_builddir)/plugins
 
 EXTRA_DIST = connman-dbus.conf connman-polkit.conf connman.rules