fixing some problems in package scripts and add info files
[findit] / debian / rules
index def22fb..334ef62 100755 (executable)
@@ -16,25 +16,29 @@ configure-stamp:
 
        touch configure-stamp
 
-
 build: build-stamp
 
-build-stamp: configure-stamp  
+build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE)
+       mkdir $(CURDIR)/ru
+       mkdir $(CURDIR)/ru/LC_MESSAGES
+       touch $(CURDIR)/ru/LC_MESSAGES/findit.mo
+       msgfmt ru.po -o $(CURDIR)/ru/LC_MESSAGES/findit.mo
+       python setup.py build
        #docbook-to-man debian/findit.sgml > findit.1
 
        touch $@
 
-clean: 
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
+       rm -rf $(CURDIR)/ru
 
        # Add here commands to clean up after the build process.
-       $(MAKE) clean
+       python setup.py clean --all
 
        dh_clean 
 
@@ -44,9 +48,8 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/findit.
-       $(MAKE) DESTDIR=$(CURDIR)/debian/findit install
-
+       # Add here commands to install the package into debian/findit
+       python setup.py install --root $(CURDIR)/debian/findit
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -59,26 +62,12 @@ binary-arch: build install
        dh_installchangelogs 
        dh_installdocs
        dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
        dh_installman
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
        dh_installdeb
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb