delete libqt4-maemo5, now libqt is finger usable...
[googlelatitude] / debian / rules
index ad1ab6f..f44f604 100755 (executable)
@@ -7,57 +7,61 @@
 # This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+export DH_VERBOSE=1
 
 APPNAME := googlelatitude
 
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-        CFLAGS += -O0
-else
-        CFLAGS += -O2
-endif
-
-builddir:
-       mkdir -p builddir
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       qmake
+       touch configure-stamp
 
-builddir/Makefile: builddir
-       cd builddir && /opt/qt4-maemo5/bin/qmake-qt4 PREFIX=/usr ../$(APPNAME).pro
-#      cd builddir && qmake-qt4 PREFIX=/usr ../$(APPNAME).pro
 build: build-stamp
-
-build-stamp: builddir/Makefile
+build-stamp: configure-stamp  
        dh_testdir
-       cd builddir && $(MAKE)
-       touch $@
+       $(MAKE)
+       touch build-stamp 
 
-clean:
+clean: 
        dh_testdir
        dh_testroot
-       rm -f build-stamp
-       rm -rf builddir
-       dh_clean
+       rm -f build-stamp configure-stamp
+       -$(MAKE) clean
+       dh_clean 
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_clean -k 
        dh_installdirs
-       cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
+       $(MAKE) DESTDIR=$(CURDIR)/debian/$(APPNAME) install
 
 binary-indep: build install
-
 binary-arch: build install
        dh_testdir
        dh_testroot
+       dh_installchangelogs 
        dh_installdocs
        dh_installexamples
+       dh_install
+       dh_installmenu
+       dh_installdebconf       
+       dh_installlogrotate
+       dh_installemacsen
+       dh_installpam
+       dh_installmime
+       dh_python
+       dh_installinit
+       dh_installcron
+       dh_installinfo
        dh_installman
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
+       dh_perl
+       dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol