rules: use BUILD_DEB_OPTIONS for n770 and n8x0 variants
[maemo-efl] / trunk / epeg / debian / rules
index f320fb5..495b7e2 100755 (executable)
@@ -2,10 +2,19 @@
 
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
 
 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 
+CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2
+                                                                                                                  
 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+       CFLAGS += -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+       ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
+               CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
+       endif
+       ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
+               CFLAGS += -mcpu=arm926ej-s
+       endif
 endif
+