Added maemo-cflags-cdbs-rules as dependency
[maemo-efl] / trunk / imlib2 / debian / rules
index 42e2a11..8404411 100755 (executable)
@@ -2,16 +2,12 @@
 
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/maemo-cflags.mk
 
+DEB_CONFIGURE_SCRIPT := ./autogen.sh
 DEB_CONFIGURE_EXTRA_FLAGS := --disable-mmx             \
                                                         --disable-amd64        \
                                                         --without-gif          \
                                                         --without-id3
 
-DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-
-ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
-endif
-
+CFLAGS += -I/usr/X11R6/include