Added gst-plugins-base-subtitles0.10-0.10.34 for Meego Harmattan 1.2
[mafwsubrenderer] / gst-plugins-base-subtitles0.10 / debian / patches / 0021-Fix-libgstpbutils-libgstvideo-linking.patch
1 From 6b907a22af2596928132d72a83366a41d0a91e1c Mon Sep 17 00:00:00 2001
2 From: =?UTF-8?q?Ren=C3=A9=20Stadler?= <rene.stadler@nokia.com>
3 Date: Thu, 3 Mar 2011 18:49:43 +0200
4 Subject: [PATCH] Fix libgstpbutils/libgstvideo linking
5
6 Not sure why this is suddenly needed, but otherwise linkage will fail
7 in our build system (though nowhere else).
8 ---
9  tests/check/Makefile.am             |    9 +++++++--
10  tests/examples/encoding/Makefile.am |    1 +
11  2 files changed, 8 insertions(+), 2 deletions(-)
12
13 diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
14 index 8b8782d..573a4b1 100644
15 --- a/tests/check/Makefile.am
16 +++ b/tests/check/Makefile.am
17 @@ -238,6 +238,7 @@ libs_discoverer_CFLAGS = \
18         -DGST_TEST_FILE="\"$(abs_top_srcdir)/tests/files/partialframe.mjpeg\""
19  libs_discoverer_LDADD = \
20         $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-@GST_MAJORMINOR@.la \
21 +       $(top_builddir)/gst-libs/gst/video/libgstvideo-@GST_MAJORMINOR@.la \
22         $(GST_BASE_LIBS) $(LDADD)
23  
24  libs_fft_CFLAGS = \
25 @@ -311,7 +312,9 @@ libs_profile_CFLAGS = \
26         $(GST_PLUGINS_BASE_CFLAGS) \
27         $(AM_CFLAGS)
28  libs_profile_LDADD = \
29 -       $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-@GST_MAJORMINOR@.la $(LDADD)
30 +       $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-@GST_MAJORMINOR@.la \
31 +       $(top_builddir)/gst-libs/gst/video/libgstvideo-@GST_MAJORMINOR@.la \
32 +       $(LDADD)
33  
34  libs_xmpwriter_CFLAGS = \
35         $(GST_PLUGINS_BASE_CFLAGS) \
36 @@ -379,7 +382,9 @@ elements_playbin2_CFLAGS = $(GST_BASE_CFLAGS) $(AM_CFLAGS)
37  elements_decodebin_LDADD = $(GST_BASE_LIBS) $(LDADD)
38  elements_decodebin_CFLAGS = $(GST_BASE_CFLAGS) $(AM_CFLAGS)
39  
40 -elements_encodebin_LDADD = $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-@GST_MAJORMINOR@.la $(GST_BASE_LIBS) $(LDADD)
41 +elements_encodebin_LDADD = $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-@GST_MAJORMINOR@.la \
42 +       $(top_builddir)/gst-libs/gst/video/libgstvideo-@GST_MAJORMINOR@.la \
43 +       $(GST_BASE_LIBS) $(LDADD)
44  elements_encodebin_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(AM_CFLAGS)
45  
46  elements_decodebin2_LDADD = $(GST_BASE_LIBS) $(LDADD)
47 diff --git a/tests/examples/encoding/Makefile.am b/tests/examples/encoding/Makefile.am
48 index 2bcc902..be3378a 100644
49 --- a/tests/examples/encoding/Makefile.am
50 +++ b/tests/examples/encoding/Makefile.am
51 @@ -6,6 +6,7 @@ EXTRA_DIST = gstcapslist.h
52  noinst_PROGRAMS = $(examples)
53  
54  LDADD = $(top_builddir)/gst-libs/gst/pbutils/libgstpbutils-@GST_MAJORMINOR@.la \
55 +        $(top_builddir)/gst-libs/gst/video/libgstvideo-@GST_MAJORMINOR@.la \
56         $(GST_LIBS)
57  AM_CFLAGS = -I$(top_builddir)/gst-libs \
58         $(GST_PLUGINS_BASE_CFLAGS) \