Added gst-plugins-base-subtitles0.10-0.10.34 for Meego Harmattan 1.2
[mafwsubrenderer] / gst-plugins-base-subtitles0.10 / debian / patches / 0028-uridecodebin-remove-some-dead-code.patch
1 From ae686aad03ab47762e6aa0017c4f33b5a8791032 Mon Sep 17 00:00:00 2001
2 From: Mark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>
3 Date: Tue, 26 Apr 2011 11:27:40 +0200
4 Subject: [PATCH] uridecodebin: remove some dead code
5
6 ... which was dead as pads were never added to the list, and need not be added,
7 since removing them is handled by a pad callback.
8 ---
9  gst/playback/gsturidecodebin.c |   19 -------------------
10  1 files changed, 0 insertions(+), 19 deletions(-)
11
12 diff --git a/gst/playback/gsturidecodebin.c b/gst/playback/gsturidecodebin.c
13 index 8c4e3f2..361b164 100644
14 --- a/gst/playback/gsturidecodebin.c
15 +++ b/gst/playback/gsturidecodebin.c
16 @@ -92,7 +92,6 @@ struct _GstURIDecodeBin
17    guint have_type_id;           /* have-type signal id from typefind */
18    GSList *decodebins;
19    GSList *pending_decodebins;
20 -  GSList *srcpads;
21    gint numpads;
22  
23    /* for dynamic sources */
24 @@ -1429,22 +1428,6 @@ remove_decoders (GstURIDecodeBin * bin, gboolean force)
25  }
26  
27  static void
28 -remove_pads (GstURIDecodeBin * bin)
29 -{
30 -  GSList *walk;
31 -
32 -  for (walk = bin->srcpads; walk; walk = g_slist_next (walk)) {
33 -    GstPad *pad = GST_PAD_CAST (walk->data);
34 -
35 -    GST_DEBUG_OBJECT (bin, "removing old pad");
36 -    gst_pad_set_active (pad, FALSE);
37 -    gst_element_remove_pad (GST_ELEMENT_CAST (bin), pad);
38 -  }
39 -  g_slist_free (bin->srcpads);
40 -  bin->srcpads = NULL;
41 -}
42 -
43 -static void
44  proxy_unknown_type_signal (GstElement * element, GstPad * pad, GstCaps * caps,
45      GstURIDecodeBin * dec)
46  {
47 @@ -2414,14 +2397,12 @@ gst_uri_decode_bin_change_state (GstElement * element,
48      case GST_STATE_CHANGE_PAUSED_TO_READY:
49        GST_DEBUG ("paused to ready");
50        remove_decoders (decoder, FALSE);
51 -      remove_pads (decoder);
52        remove_source (decoder);
53        do_async_done (decoder);
54        break;
55      case GST_STATE_CHANGE_READY_TO_NULL:
56        GST_DEBUG ("ready to null");
57        remove_decoders (decoder, TRUE);
58 -      remove_pads (decoder);
59        remove_source (decoder);
60        break;
61      default: