Added new Harmattan icon for qmafw-gst-subtitles-applet.
[mafwsubrenderer] / qmafw-gst-subtitles-renderer / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13 APPNAME = qmafw-gst-subtitles-renderer
14
15 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
16         MODE=debug
17 else
18         MODE=release
19 endif
20
21 configure: configure-stamp
22 configure-stamp:
23         dh_testdir
24         # Add here commands to configure the package.
25         qmake PREFIX=/usr MODE=$(MODE) $(APPNAME).pro && $(MAKE)
26         cd applet && qmake PREFIX=/usr MODE=$(MODE) subtitlesapplet.pro && $(MAKE) && cd ..
27
28         touch configure-stamp
29
30
31 build: build-stamp
32
33 build-stamp: configure-stamp 
34         dh_testdir
35
36         # Add here commands to compile the package.
37         $(MAKE)
38         #docbook-to-man debian/qmafw-gst-renderer.sgml > qmafw-gst-renderer.1
39
40         touch $@
41
42 clean:
43         dh_testdir
44         dh_testroot
45         rm -f build-stamp configure-stamp
46
47         # Add here commands to clean up after the build process.
48         -rm -f debian/build-stamp
49         rm -rf debian/qmafw-gst-subtitles-renderer
50         [ ! -f Makefile ] || $(MAKE) distclean
51         [ ! -f applet/Makefile ] || (cd applet && $(MAKE) distclean && cd ..)
52
53         dh_clean 
54
55 install: build
56         dh_testdir
57         dh_testroot
58         dh_clean -k 
59         dh_installdirs
60
61         # Add here commands to install the package into debian/app_name
62         $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
63         cd applet && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install && cd ..
64
65
66 # Build architecture-independent files here.
67 binary-indep: build install
68 # We have nothing to do by default.
69
70 # Build architecture-dependent files here.
71 binary-arch: build install
72         dh_testdir
73         dh_testroot
74         dh_installchangelogs 
75         dh_installdocs
76         dh_installexamples
77         dh_install -a --sourcedir=debian/$(APPNAME)
78 #       dh_installmenu
79 #       dh_installdebconf       
80 #       dh_installlogrotate
81 #       dh_installemacsen
82 #       dh_installpam
83 #       dh_installmime
84 #       dh_python
85 #       dh_installinit
86 #       dh_installcron
87 #       dh_installinfo
88         dh_installman
89         dh_link
90         dh_strip --dbg-package=libqmafw-gst-subtitles-renderer-dbg
91         dh_compress
92         dh_fixperms
93 #       dh_perl
94         dh_makeshlibs
95         dh_installdeb
96         dh_shlibdeps
97         dh_gencontrol
98         dh_md5sums
99         dh_builddeb
100
101 binary: binary-indep binary-arch
102 .PHONY: build clean binary-indep binary-arch binary install configure