Added qmafw-gst-subtitles-renderer-0.0.55 for Meego Harmattan 1.2
[mafwsubrenderer] / qmafw-gst-subtitles-renderer / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13 APPNAME = qmafw-gst-subtitles-renderer
14
15 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
16         MODE=debug
17 else
18         MODE=release
19 endif
20
21 configure: configure-stamp
22 configure-stamp:
23         dh_testdir
24         # Add here commands to configure the package.
25         qmake PREFIX=/usr MODE=$(MODE) $(APPNAME).pro && $(MAKE)
26
27         touch configure-stamp
28
29
30 build: build-stamp
31
32 build-stamp: configure-stamp 
33         dh_testdir
34
35         # Add here commands to compile the package.
36         $(MAKE)
37         #docbook-to-man debian/qmafw-gst-renderer.sgml > qmafw-gst-renderer.1
38
39         touch $@
40
41 clean:
42         dh_testdir
43         dh_testroot
44         rm -f build-stamp configure-stamp
45
46         # Add here commands to clean up after the build process.
47         -rm -f debian/build-stamp
48         [ ! -f Makefile ] || $(MAKE) distclean
49
50         dh_clean 
51
52 install: build
53         dh_testdir
54         dh_testroot
55         dh_clean -k 
56         dh_installdirs
57
58         # Add here commands to install the package into debian/app_name
59         $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
60
61
62 # Build architecture-independent files here.
63 binary-indep: build install
64 # We have nothing to do by default.
65
66 # Build architecture-dependent files here.
67 binary-arch: build install
68         dh_testdir
69         dh_testroot
70         dh_installchangelogs 
71         dh_installdocs
72         dh_installexamples
73         dh_install -a --sourcedir=debian/$(APPNAME)
74 #       dh_installmenu
75 #       dh_installdebconf       
76 #       dh_installlogrotate
77 #       dh_installemacsen
78 #       dh_installpam
79 #       dh_installmime
80 #       dh_python
81 #       dh_installinit
82 #       dh_installcron
83 #       dh_installinfo
84         dh_installman
85         dh_link
86         dh_strip --dbg-package=libqmafw-gst-subtitles-renderer-dbg
87         dh_compress
88         dh_fixperms
89 #       dh_perl
90         dh_makeshlibs
91         dh_installdeb
92         dh_shlibdeps
93         dh_gencontrol
94         dh_md5sums
95         dh_builddeb
96
97 binary: binary-indep binary-arch
98 .PHONY: build clean binary-indep binary-arch binary install configure