Added qmafw-gst-subtitles-applet package
[mafwsubrenderer] / qmafw-gst-subtitles-renderer / debian / rules
index b681d05..7d7eb7b 100755 (executable)
@@ -24,6 +24,8 @@ configure-stamp:
        # Add here commands to configure the package.
        qmake PREFIX=/usr MODE=$(MODE) $(APPNAME).pro && $(MAKE)
 
+       cd applet && qmake PREFIX=/usr MODE=$(MODE) subtitlesapplet.pro && $(MAKE) && cd ..
+
        touch configure-stamp
 
 
@@ -46,6 +48,7 @@ clean:
        # Add here commands to clean up after the build process.
        -rm -f debian/build-stamp
        [ ! -f Makefile ] || $(MAKE) distclean
+       [ ! -f applet/Makefile ] || cd applet && $(MAKE) distclean && cd ..
 
        dh_clean 
 
@@ -57,6 +60,7 @@ install: build
 
        # Add here commands to install the package into debian/app_name
        $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
+       cd applet && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install && $(MAKE) && cd ..
 
 
 # Build architecture-independent files here.