Added new Harmattan icon for qmafw-gst-subtitles-applet.
[mafwsubrenderer] / qmafw-gst-subtitles-renderer / debian / rules
index 7d7eb7b..e917198 100755 (executable)
@@ -23,7 +23,6 @@ configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
        qmake PREFIX=/usr MODE=$(MODE) $(APPNAME).pro && $(MAKE)
-
        cd applet && qmake PREFIX=/usr MODE=$(MODE) subtitlesapplet.pro && $(MAKE) && cd ..
 
        touch configure-stamp
@@ -47,8 +46,9 @@ clean:
 
        # Add here commands to clean up after the build process.
        -rm -f debian/build-stamp
+       rm -rf debian/qmafw-gst-subtitles-renderer
        [ ! -f Makefile ] || $(MAKE) distclean
-       [ ! -f applet/Makefile ] || cd applet && $(MAKE) distclean && cd ..
+       [ ! -f applet/Makefile ] || (cd applet && $(MAKE) distclean && cd ..)
 
        dh_clean 
 
@@ -60,7 +60,7 @@ install: build
 
        # Add here commands to install the package into debian/app_name
        $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
-       cd applet && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install && $(MAKE) && cd ..
+       cd applet && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install && cd ..
 
 
 # Build architecture-independent files here.