update debian files for QT version
[mancala] / debian / rules
index 416695c..26c56a2 100755 (executable)
@@ -1,67 +1,43 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
 
 # Uncomment this to turn on verbose mode.
 export DH_VERBOSE=0
 
+APPNAME := mancala
 
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+LD_LIBRARY_PATH := $(LD_LIBRARY_PATH):$(CURDIR)/debian/$(APPNAME)/opt/$(APPNAME)/lib
 
+builddir:
+       mkdir -p builddir
 
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-
-config.status: 
-       dh_testdir
-       # Add here commands to configure the package.
+builddir/Makefile: builddir
+       cd builddir && qmake-qt4 PREFIX=/opt/$(APPNAME) ../$(APPNAME).pro
 
 build: build-stamp
 
-build-stamp:  config.status
+build-stamp: builddir/Makefile
        dh_testdir
-
        # Add here commands to compile the package.
-       $(MAKE)
+       cd builddir && $(MAKE)
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp 
-
+       rm -f build-stamp
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
-       cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
-       cp -f /usr/share/misc/config.guess config.guess
-endif
-
-
+       rm -rf builddir
        dh_clean 
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean -k
        dh_installdirs
 
-       # Add here commands to install the package into debian/mancala
-       $(MAKE) DESTDIR=$(CURDIR)/debian/mancala install
+       # Add here commands to install the package into debian/your_appname
+       cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
+       
 
 
 # Build architecture-independent files here.
@@ -72,32 +48,21 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installchangelogs
-       dh_installdocs -XFAQ -XNEWS -XBUGS -XREADME.translators -XTODO -XREADME
+       dh_install --sourcedir=debian/$(APPNAME)
+#      dh_installdocs
 #      dh_installexamples
-       dh_install --sourcedir=debian/tmp
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-#      dh_installman --sourcedir=debian/tmp
+#      dh_installman
        dh_link
-       dh_strip
+#      dh_strip --dbg-package=-dbg
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
        dh_installdeb
+       echo $(LD_LIBRARY_PATH)
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install 
+.PHONY: build clean binary-indep binary-arch binary install configure
+