UIname added
[mardrone] / mardrone / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13
14
15
16 configure: configure-stamp
17 configure-stamp:
18         dh_testdir
19         # Add here commands to configure the package.
20
21         touch configure-stamp
22
23
24 build: build-stamp
25
26 build-stamp: configure-stamp  
27         dh_testdir
28
29         # Add here commands to compile the package.
30         qmake
31         $(MAKE)
32         #docbook-to-man debian/mardrone.sgml > mardrone.1
33
34         touch $@
35
36 clean: 
37         dh_testdir
38         dh_testroot
39         rm -f build-stamp configure-stamp
40
41         # Add here commands to clean up after the build process.
42         $(MAKE) clean
43
44         dh_clean 
45
46 install: build
47         dh_testdir
48         dh_testroot
49         dh_clean -k 
50         dh_installdirs
51
52         # Add here commands to install the package into debian/mardrone.
53         $(MAKE) INSTALL_ROOT="$(CURDIR)"/debian/mardrone install
54
55
56 # Build architecture-independent files here.
57 binary-indep: build install
58 # We have nothing to do by default.
59
60 # Build architecture-dependent files here.
61 binary-arch: build install
62         dh_testdir
63         dh_testroot
64         dh_installchangelogs 
65         dh_installdocs
66         dh_installexamples
67 #       dh_install
68 #       dh_installmenu
69 #       dh_installdebconf       
70 #       dh_installlogrotate
71 #       dh_installemacsen
72 #       dh_installpam
73 #       dh_installmime
74 #       dh_python
75 #       dh_installinit
76 #       dh_installcron
77 #       dh_installinfo
78         dh_installman
79         dh_link
80         # dh_strip
81         dh_compress
82         dh_fixperms
83 #       dh_perl
84 #       dh_makeshlibs
85         dh_installdeb
86         dh_shlibdeps
87         dh_gencontrol
88         dh_md5sums
89         dh_builddeb
90
91 binary: binary-indep binary-arch
92 .PHONY: build clean binary-indep binary-arch binary install configure