* debian packaging updates
[modest] / debian / rules
index 33c7093..0d627aa 100755 (executable)
@@ -13,43 +13,37 @@ DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 
-CFLAGS = -Wall -Wno-format -g
+CFLAGS = -Wall -g
+PACKAGENAME = modest
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
+#      CFLAGS += -O2
        CFLAGS += -O2
 endif
 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
-ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
-        CFLAGS += -mthumb
-endif
-
 
-# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
-version=`ls libmodest-dbus-client/.libs/lib*.so.* | \
- awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
-major=`ls libmodest-dbus-client/.libs/lib*.so.* | \
- awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
-   
-
-config.status:
-       if [ ! -x configure ]; then ./autogen.sh; fi
+config.status: configure
        dh_testdir
-       # Add here commands to configure the package.
+       # commands to configure the package.
        CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
 
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       ./autogen.sh
+       touch configure-stamp
 
 build: build-stamp
 
 build-stamp:  config.status
        dh_testdir
 
-       # Add here commands to compile the package.
-       $(MAKE)
-
+       # commands to compile the package.
+       $(MAKE) 
        touch build-stamp
 
 clean:
@@ -57,7 +51,7 @@ clean:
        dh_testroot
        rm -f build-stamp 
 
-       # Add here commands to clean up after the build process.
+       # commands to clean up after the build process.
        -$(MAKE) distclean
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
@@ -75,9 +69,9 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/modest
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/modest
-
+       # install the package into debian/tmp/
+       #
+       $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -85,12 +79,12 @@ binary-indep: build install
 
 # Build architecture-dependent files here.
 binary-arch: build install
-       dh_testdir -a
-       dh_testroot -a 
-       dh_installchangelogs ChangeLog
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs 
        dh_installdocs
-#      dh_installexamples
-       dh_install --sourcedir=debian/modest 
+       dh_installexamples
+       dh_install --sourcedir=debian/tmp -v
        dh_installmenu
 #      dh_installdebconf       
 #      dh_installlogrotate
@@ -101,18 +95,18 @@ binary-arch: build install
 #      dh_installcron
 #      dh_installinfo
        dh_installman
-       dh_link -a
-       dh_strip -a --dbg-package="modest" 
-       dh_compress -a
-       dh_fixperms -a
+       dh_link
+       dh_strip --dbg-package="modest-dbg"
+       dh_compress
+       dh_fixperms
 #      dh_perl
 #      dh_python
-       dh_makeshlibs -a -V 
+#      dh_makeshlibs
        dh_installdeb
-       dh_shlibdeps -V
-       dh_gencontrol
+       dh_shlibdeps
+       dh_gencontrol 
        dh_md5sums
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install 
+.PHONY: build clean binary-indep binary-arch binary install