* debian packaging updates
[modest] / debian / rules
index e4d3310..0d627aa 100755 (executable)
@@ -14,10 +14,12 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 
 CFLAGS = -Wall -g
+PACKAGENAME = modest
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
+#      CFLAGS += -O2
        CFLAGS += -O2
 endif
 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
@@ -26,19 +28,22 @@ endif
 
 config.status: configure
        dh_testdir
-       # Add here commands to configure the package.
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
+       # commands to configure the package.
+       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
 
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       ./autogen.sh
+       touch configure-stamp
 
 build: build-stamp
 
 build-stamp:  config.status
        dh_testdir
 
-       # Add here commands to compile the package.
-       $(MAKE)
-       #/usr/bin/docbook-to-man debian/modest.sgml > modest.1
-
+       # commands to compile the package.
+       $(MAKE) 
        touch build-stamp
 
 clean:
@@ -46,7 +51,7 @@ clean:
        dh_testroot
        rm -f build-stamp 
 
-       # Add here commands to clean up after the build process.
+       # commands to clean up after the build process.
        -$(MAKE) distclean
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
@@ -64,9 +69,9 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/modest.
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/modest
-
+       # install the package into debian/tmp/
+       #
+       $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -76,11 +81,11 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs ChangeLog
-#      dh_installdocs
-#      dh_installexamples
-#      dh_install
-#      dh_installmenu
+       dh_installchangelogs 
+       dh_installdocs
+       dh_installexamples
+       dh_install --sourcedir=debian/tmp -v
+       dh_installmenu
 #      dh_installdebconf       
 #      dh_installlogrotate
 #      dh_installemacsen
@@ -91,17 +96,17 @@ binary-arch: build install
 #      dh_installinfo
        dh_installman
        dh_link
-       dh_strip
+       dh_strip --dbg-package="modest-dbg"
        dh_compress
        dh_fixperms
 #      dh_perl
 #      dh_python
-       dh_makeshlibs
+#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
-       dh_gencontrol
+       dh_gencontrol 
        dh_md5sums
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install 
+.PHONY: build clean binary-indep binary-arch binary install