* we were assuming that the source of a 'new folder' thing always
[modest] / debian / rules
index 491fcc7..2a0afbd 100755 (executable)
@@ -26,16 +26,16 @@ ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
 endif
 
 # maemo-launcher support is not working properly yet, so leave it disabled
-# ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
-#      LAUNCHER = yes
-#      conf_opt := --enable-maemo-launcher
-# endif
+#DEB_BUILD_OPTIONS := $(DEB_BUILD_OPTIONS),nolauncher
+#ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
+#      conf_opt := --enable-maemo-launcher
+#endif
 
 config.status: configure
        dh_testdir
        # commands to configure the package.
        if [ ! -x configure ]; then ./autogen.sh; fi
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info $(conf_opt)
+       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --disable-maemo-launcher --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info $(conf_opt)
 
 configure: configure-stamp
 configure-stamp:
@@ -77,13 +77,6 @@ install: build
 # install the package into debian/tmp/
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
 
-ifeq "$(strip $(LAUNCHER))" "yes"
-       mv $(CURDIR)/debian/tmp/usr/bin/modest \
-       $(CURDIR)/debian/modest/usr/bin/modest.launch
-       ln -s /usr/bin/maemo-invoker \
-       $(CURDIR)/debian/modest/usr/bin/modest
-endif
-
 # ACHTUNG: hack
 # we remove the modest.mo english localization, if the current control file contains a reference
 # to modest-l10n-mr0; thus, the modest package will not conflict with that one.
@@ -122,7 +115,9 @@ binary-arch: build install
        dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
-       dh_gencontrol -- $(LAUNCHER_DEPENDS)
+       # Not a requirement by now, so don't fail if it's not installed
+#      which dh_maemolauncher && dh_maemolauncher usr/bin/modest || true
+       dh_gencontrol
        dh_md5sums
        dh_builddeb