* Fixed an small leak
[modest] / debian / rules
index 6384dfb..2aa12e7 100755 (executable)
@@ -1,48 +1,47 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-
 CFLAGS = -Wall -g
 PACKAGENAME = modest
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
-#      CFLAGS += -O2
        CFLAGS += -O2
 endif
 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
 
+ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
+        CFLAGS += -mthumb
+endif
 
-#LAUNCHER = no 
+LAUNCHER = no
 #ifneq (,$(findstring maemo-launcher,$(DEB_BUILD_OPTIONS)))
 #      LAUNCHER = yes
 #endif
-#
-#ifeq "$(strip $(LAUNCHER))" "yes"
-#      LAUNCHER_DEPENDS = -Vlauncher:Depends="maemo-launcher"
-#      LAUNCHER_CFLAGS = -shared
-#      LAUNCHER_LDFLAGS = -pie -shared -export-dynamic
-#endif
 
+ifeq "$(strip $(LAUNCHER))" "yes"
+       LAUNCHER_DEPENDS = -Vlauncher:Depends="maemo-launcher"
+       LAUNCHER_CFLAGS = -shared
+       LAUNCHER_LDFLAGS = -pie -shared -export-dynamic
+       CFLAGS += -fPIC
+endif
 
 
 config.status: configure
        dh_testdir
        # commands to configure the package.
+       if [ ! -x configure ]; then ./autogen.sh; fi
        CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
 
 configure: configure-stamp
@@ -56,18 +55,19 @@ build: build-stamp
 build-stamp:  config.status
        dh_testdir
 
-       # commands to compile the package.
+        # commands to compile the package.
        $(MAKE) \
-        MAEMO_LAUNCHER_CFLAGS="$(LAUNCHER_CFLAGS)" \
-        MAEMO_LAUNCHER_LDFLAGS="$(LAUNCHER_LDFLAGS)"
+         MAEMO_LAUNCHER_CFLAGS="$(LAUNCHER_CFLAGS)" \
+         MAEMO_LAUNCHER_LDFLAGS="$(LAUNCHER_LDFLAGS)"
        touch build-stamp
 
+
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp 
 
-       # commands to clean up after the build process.
+# commands to clean up after the build process.
        -$(MAKE) distclean
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
@@ -75,8 +75,6 @@ endif
 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
-
-
        dh_clean 
 
 install: build
@@ -85,16 +83,22 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # install the package into debian/tmp/
-       #
+# install the package into debian/tmp/
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
 
-#ifeq "$(strip $(LAUNCHER))" "yes"
-#      mv $(CURDIR)/debian/modest/usr/bin/modest \
-#      $(CURDIR)/debian/modest/usr/bin/modest.launch
-#      ln -s /usr/bin/maemo-invoker \
-#              $(CURDIR)/debian/modest/usr/bin/modest
-#endif
+ifeq "$(strip $(LAUNCHER))" "yes"
+       mv $(CURDIR)/debian/tmp/usr/bin/modest \
+       $(CURDIR)/debian/modest/usr/bin/modest.launch
+       ln -s /usr/bin/maemo-invoker \
+       $(CURDIR)/debian/modest/usr/bin/modest
+endif
+
+# ACHTUNG: hack
+# we remove the modest.mo english localization, if the current control file contains a reference
+# to modest-l10n-mr0; thus, the modest package will not conflict with that one.
+# if modest-l10n-mr0 is not there, we'll install our own (en_GB) .mo file.
+       if grep -q modest-l10n-mr0 $(CURDIR)/debian/control ; then rm $(CURDIR)/debian/tmp/usr/share/locale/en_GB/LC_MESSAGES/modest.mo ; else echo "modest.mo not removed."; fi
+
 
 # Build architecture-independent files here.
 binary-indep: build install