* Fixed an small leak
[modest] / debian / rules
index 784d4cb..2aa12e7 100755 (executable)
@@ -34,6 +34,7 @@ ifeq "$(strip $(LAUNCHER))" "yes"
        LAUNCHER_DEPENDS = -Vlauncher:Depends="maemo-launcher"
        LAUNCHER_CFLAGS = -shared
        LAUNCHER_LDFLAGS = -pie -shared -export-dynamic
+       CFLAGS += -fPIC
 endif
 
 
@@ -60,6 +61,7 @@ build-stamp:  config.status
          MAEMO_LAUNCHER_LDFLAGS="$(LAUNCHER_LDFLAGS)"
        touch build-stamp
 
+
 clean:
        dh_testdir
        dh_testroot
@@ -91,6 +93,13 @@ ifeq "$(strip $(LAUNCHER))" "yes"
        $(CURDIR)/debian/modest/usr/bin/modest
 endif
 
+# ACHTUNG: hack
+# we remove the modest.mo english localization, if the current control file contains a reference
+# to modest-l10n-mr0; thus, the modest package will not conflict with that one.
+# if modest-l10n-mr0 is not there, we'll install our own (en_GB) .mo file.
+       if grep -q modest-l10n-mr0 $(CURDIR)/debian/control ; then rm $(CURDIR)/debian/tmp/usr/share/locale/en_GB/LC_MESSAGES/modest.mo ; else echo "modest.mo not removed."; fi
+
+
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.