* Fixed an small leak
[modest] / debian / rules
index 9588eb3..2aa12e7 100755 (executable)
@@ -21,15 +21,20 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
 
-LAUNCHER = yes
-ifneq (,$(findstring maemo-launcher,$(DEB_BUILD_OPTIONS)))
-       LAUNCHER = yes
+ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
+        CFLAGS += -mthumb
 endif
 
+LAUNCHER = no
+#ifneq (,$(findstring maemo-launcher,$(DEB_BUILD_OPTIONS)))
+#      LAUNCHER = yes
+#endif
+
 ifeq "$(strip $(LAUNCHER))" "yes"
        LAUNCHER_DEPENDS = -Vlauncher:Depends="maemo-launcher"
        LAUNCHER_CFLAGS = -shared
        LAUNCHER_LDFLAGS = -pie -shared -export-dynamic
+       CFLAGS += -fPIC
 endif
 
 
@@ -56,12 +61,13 @@ build-stamp:  config.status
          MAEMO_LAUNCHER_LDFLAGS="$(LAUNCHER_LDFLAGS)"
        touch build-stamp
 
+
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp 
 
-       # commands to clean up after the build process.
+# commands to clean up after the build process.
        -$(MAKE) distclean
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
@@ -77,7 +83,7 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # install the package into debian/tmp/
+# install the package into debian/tmp/
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
 
 ifeq "$(strip $(LAUNCHER))" "yes"
@@ -87,6 +93,13 @@ ifeq "$(strip $(LAUNCHER))" "yes"
        $(CURDIR)/debian/modest/usr/bin/modest
 endif
 
+# ACHTUNG: hack
+# we remove the modest.mo english localization, if the current control file contains a reference
+# to modest-l10n-mr0; thus, the modest package will not conflict with that one.
+# if modest-l10n-mr0 is not there, we'll install our own (en_GB) .mo file.
+       if grep -q modest-l10n-mr0 $(CURDIR)/debian/control ; then rm $(CURDIR)/debian/tmp/usr/share/locale/en_GB/LC_MESSAGES/modest.mo ; else echo "modest.mo not removed."; fi
+
+
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.