changing dependencies for public release
[modest] / debian / rules
index 64e6c91..2daa7f7 100755 (executable)
@@ -25,17 +25,19 @@ ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -mthumb
 endif
 
-# maemo-launcher support is not working properly yet, so leave it disabled
-#DEB_BUILD_OPTIONS := $(DEB_BUILD_OPTIONS),nolauncher
-#ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
-#      conf_opt := --enable-maemo-launcher
-#endif
+ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
+       conf_opt = --enable-maemo-launcher
+endif
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       conf_opt += --enable-debug
+endif
 
 config.status: configure
        dh_testdir
        # commands to configure the package.
        if [ ! -x configure ]; then ./autogen.sh; fi
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --disable-maemo-launcher --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info $(conf_opt)
+       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info $(conf_opt)
 
 configure: configure-stamp
 configure-stamp:
@@ -116,9 +118,9 @@ binary-arch: build install
        dh_installdeb
        dh_shlibdeps
        # Not a requirement by now, so don't fail if it's not installed
-#      which dh_maemolauncher && dh_maemolauncher usr/bin/modest || true
+       which dh_maemolauncher && dh_maemolauncher usr/bin/modest || true
        dh_gencontrol
-       sh debian/scripts/renew_control_file.sh
+#      sh debian/scripts/renew_control_file.sh
        dh_md5sums
        dh_builddeb