version and bug fix info update for week 14, 2009 - thursday release
[modest] / debian / rules
index 784d4cb..2daa7f7 100755 (executable)
@@ -25,23 +25,19 @@ ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -mthumb
 endif
 
-LAUNCHER = no
-#ifneq (,$(findstring maemo-launcher,$(DEB_BUILD_OPTIONS)))
-#      LAUNCHER = yes
-#endif
-
-ifeq "$(strip $(LAUNCHER))" "yes"
-       LAUNCHER_DEPENDS = -Vlauncher:Depends="maemo-launcher"
-       LAUNCHER_CFLAGS = -shared
-       LAUNCHER_LDFLAGS = -pie -shared -export-dynamic
+ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
+       conf_opt = --enable-maemo-launcher
 endif
 
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       conf_opt += --enable-debug
+endif
 
 config.status: configure
        dh_testdir
        # commands to configure the package.
        if [ ! -x configure ]; then ./autogen.sh; fi
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
+       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info $(conf_opt)
 
 configure: configure-stamp
 configure-stamp:
@@ -55,11 +51,10 @@ build-stamp:  config.status
        dh_testdir
 
         # commands to compile the package.
-       $(MAKE) \
-         MAEMO_LAUNCHER_CFLAGS="$(LAUNCHER_CFLAGS)" \
-         MAEMO_LAUNCHER_LDFLAGS="$(LAUNCHER_LDFLAGS)"
+       $(MAKE)
        touch build-stamp
 
+
 clean:
        dh_testdir
        dh_testroot
@@ -84,12 +79,12 @@ install: build
 # install the package into debian/tmp/
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
 
-ifeq "$(strip $(LAUNCHER))" "yes"
-       mv $(CURDIR)/debian/tmp/usr/bin/modest \
-       $(CURDIR)/debian/modest/usr/bin/modest.launch
-       ln -s /usr/bin/maemo-invoker \
-       $(CURDIR)/debian/modest/usr/bin/modest
-endif
+# ACHTUNG: hack
+# we remove the modest.mo english localization, if the current control file contains a reference
+# to modest-l10n-mr0; thus, the modest package will not conflict with that one.
+# if modest-l10n-mr0 is not there, we'll install our own (en_GB) .mo file.
+       if grep -q modest-l10n-mr0 $(CURDIR)/debian/control ; then rm $(CURDIR)/debian/tmp/usr/share/locale/en_GB/LC_MESSAGES/modest.mo ; else echo "modest.mo not removed."; fi
+
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -122,7 +117,10 @@ binary-arch: build install
        dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
-       dh_gencontrol -- $(LAUNCHER_DEPENDS)
+       # Not a requirement by now, so don't fail if it's not installed
+       which dh_maemolauncher && dh_maemolauncher usr/bin/modest || true
+       dh_gencontrol
+#      sh debian/scripts/renew_control_file.sh
        dh_md5sums
        dh_builddeb