removing dependencies of libprofile-dev, profile-data-dev, libosso-abook-dev and...
[modest] / debian / rules
index e517f87..2daa7f7 100755 (executable)
@@ -25,10 +25,12 @@ ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -mthumb
 endif
 
-# maemo-launcher support is not working properly yet, so leave it disabled
-DEB_BUILD_OPTIONS := $(DEB_BUILD_OPTIONS),nolauncher
 ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
-       conf_opt := --enable-maemo-launcher
+       conf_opt = --enable-maemo-launcher
+endif
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       conf_opt += --enable-debug
 endif
 
 config.status: configure
@@ -115,8 +117,10 @@ binary-arch: build install
        dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
-       dh_maemolauncher usr/bin/modest
+       # Not a requirement by now, so don't fail if it's not installed
+       which dh_maemolauncher && dh_maemolauncher usr/bin/modest || true
        dh_gencontrol
+#      sh debian/scripts/renew_control_file.sh
        dh_md5sums
        dh_builddeb