Fixes NB#115566, do not show "invalid username or password" on connection errors
[modest] / debian / rules
index fd0a3ae..34a45e8 100755 (executable)
@@ -25,8 +25,6 @@ ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -mthumb
 endif
 
-# maemo-launcher support is not working properly yet, so leave it disabled
-#DEB_BUILD_OPTIONS := $(DEB_BUILD_OPTIONS),nolauncher
 ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
        conf_opt = --enable-maemo-launcher
 endif
@@ -63,7 +61,9 @@ clean:
        rm -f build-stamp 
 
 # commands to clean up after the build process.
-       -$(MAKE) distclean
+#      -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
+
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
 endif
@@ -122,7 +122,7 @@ binary-arch: build install
        # Not a requirement by now, so don't fail if it's not installed
        which dh_maemolauncher && dh_maemolauncher usr/bin/modest || true
        dh_gencontrol
-       sh debian/scripts/renew_control_file.sh
+#      sh debian/scripts/renew_control_file.sh
        dh_md5sums
        dh_builddeb