Fixed typo
[modest] / debian / rules
index 784d4cb..35e7f9a 100755 (executable)
@@ -26,14 +26,15 @@ ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
 endif
 
 LAUNCHER = no
-#ifneq (,$(findstring maemo-launcher,$(DEB_BUILD_OPTIONS)))
-#      LAUNCHER = yes
-#endif
+ifneq (,$(findstring maemo-launcher,$(DEB_BUILD_OPTIONS)))
+       LAUNCHER = yes
+endif
 
 ifeq "$(strip $(LAUNCHER))" "yes"
        LAUNCHER_DEPENDS = -Vlauncher:Depends="maemo-launcher"
        LAUNCHER_CFLAGS = -shared
        LAUNCHER_LDFLAGS = -pie -shared -export-dynamic
+       CFLAGS += -fPIC
 endif