* Added two missing "debian", because CURDIR is the root folder
[modest] / debian / rules
index a4ee397..4a2834e 100755 (executable)
@@ -1,44 +1,47 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-
 CFLAGS = -Wall -g
 PACKAGENAME = modest
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
-#      CFLAGS += -O2
        CFLAGS += -O2
 endif
 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
 
-ifneq (,$(findstring maemo-launcher,$(DEB_BUILD_OPTIONS)))
-       LAUNCHER = yes
+ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
+        CFLAGS += -mthumb
 endif
 
+LAUNCHER = no
+#ifneq (,$(findstring maemo-launcher,$(DEB_BUILD_OPTIONS)))
+#      LAUNCHER = yes
+#endif
+
 ifeq "$(strip $(LAUNCHER))" "yes"
        LAUNCHER_DEPENDS = -Vlauncher:Depends="maemo-launcher"
        LAUNCHER_CFLAGS = -shared
-       LAUNCHER_LDFLAGS = -shared -export-dynamic
+       LAUNCHER_LDFLAGS = -pie -shared -export-dynamic
+       CFLAGS += -fPIC
 endif
 
+
 config.status: configure
        dh_testdir
        # commands to configure the package.
+       if [ ! -x configure ]; then ./autogen.sh; fi
        CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
 
 configure: configure-stamp
@@ -52,20 +55,19 @@ build: build-stamp
 build-stamp:  config.status
        dh_testdir
 
-       # commands to compile the package.
+        # commands to compile the package.
        $(MAKE) \
-         MAEMO_LAUNCHER_CFLAGS="$(LAUNCHER_CFLAGS)" \
-         MAEMO_LAUNCHER_LDFLAGS="$(LAUNCHER_LDFLAGS)"
-       #/usr/bin/docbook-to-man debian/osso-sketch.sgml > osso-sketch.1
-
+         MAEMO_LAUNCHER_CFLAGS="$(LAUNCHER_CFLAGS)" \
+         MAEMO_LAUNCHER_LDFLAGS="$(LAUNCHER_LDFLAGS)"
        touch build-stamp
 
+
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp 
 
-       # commands to clean up after the build process.
+# commands to clean up after the build process.
        -$(MAKE) distclean
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
@@ -73,8 +75,6 @@ endif
 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
        cp -f /usr/share/misc/config.guess config.guess
 endif
-
-
        dh_clean 
 
 install: build
@@ -83,17 +83,23 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # install the package into debian/tmp/
-       #
+# install the package into debian/tmp/
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
 
 ifeq "$(strip $(LAUNCHER))" "yes"
        mv $(CURDIR)/debian/tmp/usr/bin/modest \
-          $(CURDIR)/debian/tmp/usr/bin/modest.launch
+       $(CURDIR)/debian/modest/usr/bin/modest.launch
        ln -s /usr/bin/maemo-invoker \
-             $(CURDIR)/debian/tmp/usr/bin/modest
+       $(CURDIR)/debian/modest/usr/bin/modest
 endif
 
+# ACHTUNG: hack
+# we remove the modest.mo english localization, if the current control file contains a reference
+# to modest-l10n-mr0; thus, the modest package will not conflict with that one.
+# if modest-l10n-mr0 is not there, we'll install our own (en_GB) .mo file.
+       grep modest-l10n-mr0 $(CURDIR)/debian/control && rm $(CURDIR)/debian/tmp/usr/share/locale/en_GB/LC_MESSAGES/modest.mo   
+
+
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.
@@ -106,7 +112,7 @@ binary-arch: build install
        dh_installdocs
        dh_installexamples
        dh_install --sourcedir=debian/tmp -v
-#      dh_installmenu
+       dh_installmenu
 #      dh_installdebconf       
 #      dh_installlogrotate
 #      dh_installemacsen
@@ -115,14 +121,14 @@ binary-arch: build install
 #      dh_installinit
 #      dh_installcron
 #      dh_installinfo
-#      dh_installman
+       dh_installman
        dh_link
-       dh_strip --dbg-package=modest
+       dh_strip --keep-debug --dbg-package=modest --dbg-package=libmodest-dbus-client
        dh_compress
        dh_fixperms
 #      dh_perl
 #      dh_python
-#      dh_makeshlibs
+       dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol -- $(LAUNCHER_DEPENDS)