* Added two missing "debian", because CURDIR is the root folder
[modest] / debian / rules
index dbcc719..4a2834e 100755 (executable)
@@ -26,14 +26,15 @@ ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
 endif
 
 LAUNCHER = no
-ifneq (,$(findstring maemo-launcher,$(DEB_BUILD_OPTIONS)))
-       LAUNCHER = yes
-endif
+#ifneq (,$(findstring maemo-launcher,$(DEB_BUILD_OPTIONS)))
+#      LAUNCHER = yes
+#endif
 
 ifeq "$(strip $(LAUNCHER))" "yes"
        LAUNCHER_DEPENDS = -Vlauncher:Depends="maemo-launcher"
        LAUNCHER_CFLAGS = -shared
        LAUNCHER_LDFLAGS = -pie -shared -export-dynamic
+       CFLAGS += -fPIC
 endif
 
 
@@ -60,6 +61,7 @@ build-stamp:  config.status
          MAEMO_LAUNCHER_LDFLAGS="$(LAUNCHER_LDFLAGS)"
        touch build-stamp
 
+
 clean:
        dh_testdir
        dh_testroot
@@ -91,6 +93,13 @@ ifeq "$(strip $(LAUNCHER))" "yes"
        $(CURDIR)/debian/modest/usr/bin/modest
 endif
 
+# ACHTUNG: hack
+# we remove the modest.mo english localization, if the current control file contains a reference
+# to modest-l10n-mr0; thus, the modest package will not conflict with that one.
+# if modest-l10n-mr0 is not there, we'll install our own (en_GB) .mo file.
+       grep modest-l10n-mr0 $(CURDIR)/debian/control && rm $(CURDIR)/debian/tmp/usr/share/locale/en_GB/LC_MESSAGES/modest.mo   
+
+
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.