Do not show account settings dialog if the UI is not shown.
[modest] / debian / rules
index 2a0afbd..742754d 100755 (executable)
@@ -25,17 +25,19 @@ ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -mthumb
 endif
 
-# maemo-launcher support is not working properly yet, so leave it disabled
-#DEB_BUILD_OPTIONS := $(DEB_BUILD_OPTIONS),nolauncher
-#ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
-#      conf_opt := --enable-maemo-launcher
-#endif
+ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
+       conf_opt = --enable-maemo-launcher
+endif
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       conf_opt += --enable-debug
+endif
 
 config.status: configure
        dh_testdir
        # commands to configure the package.
        if [ ! -x configure ]; then ./autogen.sh; fi
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --disable-maemo-launcher --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info $(conf_opt)
+       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --sysconfdir=/etc --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info $(conf_opt)
 
 configure: configure-stamp
 configure-stamp:
@@ -59,7 +61,9 @@ clean:
        rm -f build-stamp 
 
 # commands to clean up after the build process.
-       -$(MAKE) distclean
+#      -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
+
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
 endif
@@ -107,7 +111,7 @@ binary-arch: build install
 #      dh_installinfo
        dh_installman
        dh_link
-       dh_strip --keep-debug --dbg-package=modest --dbg-package=libmodest-dbus-client
+       dh_strip --keep-debug --dbg-package=modest
        dh_compress
        dh_fixperms
 #      dh_perl
@@ -116,8 +120,9 @@ binary-arch: build install
        dh_installdeb
        dh_shlibdeps
        # Not a requirement by now, so don't fail if it's not installed
-#      which dh_maemolauncher && dh_maemolauncher usr/bin/modest || true
+       which dh_maemolauncher && dh_maemolauncher usr/bin/modest || true
        dh_gencontrol
+#      sh debian/scripts/renew_control_file.sh
        dh_md5sums
        dh_builddeb