Fixes NB#137949, show notifications even if the application is in the foreground
[modest] / debian / rules
index 2daa7f7..742754d 100755 (executable)
@@ -61,7 +61,9 @@ clean:
        rm -f build-stamp 
 
 # commands to clean up after the build process.
-       -$(MAKE) distclean
+#      -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
+
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
 endif
@@ -109,7 +111,7 @@ binary-arch: build install
 #      dh_installinfo
        dh_installman
        dh_link
-       dh_strip --keep-debug --dbg-package=modest --dbg-package=libmodest-dbus-client
+       dh_strip --keep-debug --dbg-package=modest
        dh_compress
        dh_fixperms
 #      dh_perl