Do not show account settings dialog if the UI is not shown.
[modest] / debian / rules
index 8c18f98..742754d 100755 (executable)
@@ -25,12 +25,13 @@ ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
         CFLAGS += -mthumb
 endif
 
-# maemo-launcher support is not working properly yet, so leave it disabled
-# ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
-#      LAUNCHER = yes
-#      LAUNCHER_DEPENDS=-Vlauncher:Depends="maemo-launcher"
-#      conf_opt := --enable-maemo-launcher
-# endif
+ifeq (,$(findstring nolauncher,$(DEB_BUILD_OPTIONS)))
+       conf_opt = --enable-maemo-launcher
+endif
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       conf_opt += --enable-debug
+endif
 
 config.status: configure
        dh_testdir
@@ -60,7 +61,9 @@ clean:
        rm -f build-stamp 
 
 # commands to clean up after the build process.
-       -$(MAKE) distclean
+#      -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
+
 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
        cp -f /usr/share/misc/config.sub config.sub
 endif
@@ -78,13 +81,6 @@ install: build
 # install the package into debian/tmp/
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
 
-ifeq "$(strip $(LAUNCHER))" "yes"
-       mv $(CURDIR)/debian/tmp/usr/bin/modest \
-       $(CURDIR)/debian/modest/usr/bin/modest.launch
-       ln -s /usr/bin/maemo-invoker \
-       $(CURDIR)/debian/modest/usr/bin/modest
-endif
-
 # ACHTUNG: hack
 # we remove the modest.mo english localization, if the current control file contains a reference
 # to modest-l10n-mr0; thus, the modest package will not conflict with that one.
@@ -115,7 +111,7 @@ binary-arch: build install
 #      dh_installinfo
        dh_installman
        dh_link
-       dh_strip --keep-debug --dbg-package=modest --dbg-package=libmodest-dbus-client
+       dh_strip --keep-debug --dbg-package=modest
        dh_compress
        dh_fixperms
 #      dh_perl
@@ -123,7 +119,10 @@ binary-arch: build install
        dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
-       dh_gencontrol -- $(LAUNCHER_DEPENDS)
+       # Not a requirement by now, so don't fail if it's not installed
+       which dh_maemolauncher && dh_maemolauncher usr/bin/modest || true
+       dh_gencontrol
+#      sh debian/scripts/renew_control_file.sh
        dh_md5sums
        dh_builddeb