* Added a new account key called type for server accounts
[modest] / docs / reference / Makefile.am
index e02b510..14fbb5f 100644 (file)
@@ -9,7 +9,7 @@
 DOC_MODULE=modest
 
 # The top-level SGML file. You can change this if you want to.
-DOC_MAIN_SGML_FILE=modest-docs.sgml
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
 
 # The directory containing the source code. Relative to $(srcdir).
 # gtk-doc will search all .c & .h files beneath here for inline comments
@@ -55,7 +55,7 @@ HTML_IMAGES=
 
 # Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
 # e.g. content_files=running.sgml building.sgml changes-2.0.sgml
-content_files=#xml/tree_index.sgml
+content_files=xml/tree_index.sgml
 
 # SGML files where gtk-doc abbrevations (#GtkWidget) are expanded
 # These files must be listed here *and* in content_files
@@ -84,16 +84,19 @@ GTKDOC_LIBS=\
        ${top_builddir}/src/modest-account-mgr.o \
        ${top_builddir}/src/modest-tny-platform-factory.o \
        ${top_builddir}/src/modest-protocol-mgr.o \
+       ${top_builddir}/src/modest-proto.o \
        ${top_builddir}/src/modest-pair.o \
        ${top_builddir}/src/modest-marshal.o \
        ${top_builddir}/src/modest-tny-account-store.o \
        ${top_builddir}/src/modest-mail-operation.o \
+       ${top_builddir}/src/modest-mail-operation-queue.o \
        ${top_builddir}/src/modest-tny-msg-actions.o \
        ${top_builddir}/src/modest-tny-attachment.o \
        ${top_builddir}/src/modest-tny-stream-gtkhtml.o \
        ${top_builddir}/src/modest-widget-factory.o \
        ${top_builddir}/src/modest-widget-memory.o \
        ${top_builddir}/src/modest-icon-factory.o \
+       ${top_builddir}/src/modest-formatter.o \
        ${top_builddir}/src/modest-text-utils.o
 
 # This includes the standard gtk-doc make rules, copied by gtkdocize.