Do ignore empty recipients when checking names
[modest] / src / Makefile.am
index 8592a26..5f73136 100644 (file)
@@ -15,7 +15,7 @@ INCLUDES=\
        $(MODEST_LIBCONIC_CFLAGS)                               \
        $(MODEST_HILDON_NOTIFY_CFLAGS)                          \
        $(MODEST_MOZEMBED_CFLAGS)                               \
-       -fPIC \
+       -fPIC                                                   \
        -I$(MODEST_TOOLKIT_DIR)                                 \
        -DPREFIX=\"@prefix@\"                                   \
        -DMAEMO_CHANGES                                         \
@@ -39,10 +39,6 @@ noinst_LTLIBRARIES = libmodest.la
 bin_PROGRAMS=\
        modest
 
-to_remove=\
-       modest-testplugin-protocol.c \
-       modest-testplugin-protocol.h
-
 #
 # NOTE: $(addressbook) will be modest-addressbook-dummy.c
 # if no real addressbook has been defined (configure.ac)
@@ -55,6 +51,10 @@ modest_public_headers = \
        modest-account-settings.h \
        modest-cache-mgr.h \
        modest-conf.h \
+       modest-defs.h \
+       modest-local-folder-info.h \
+       modest-mail-operation.h \
+       modest-mail-operation-queue.h \
        modest-pair.h \
        modest-platform.h \
        modest-plugin.h \
@@ -62,9 +62,12 @@ modest_public_headers = \
        modest-protocol.h \
        modest-protocol-registry.h \
        modest-server-account-settings.h \
+       modest-signal-mgr.h \
        modest-text-utils.h \
        modest-tny-account-store.h \
+       modest-tny-folder.h \
        modest-tny-local-folders-account.h \
+       modest-tny-send-queue.h \
        modest-utils.h
 
 libmodest_la_SOURCES=\
@@ -82,7 +85,7 @@ libmodest_la_SOURCES=\
        modest-datetime-formatter.c \
        modest-datetime-formatter.h \
        modest-debug.h \
-       modest-defs.h \
+       modest-defs.c \
        modest-dimming-rule.c \
        modest-dimming-rule.h \
        modest-dimming-rules-group.c \
@@ -95,7 +98,6 @@ libmodest_la_SOURCES=\
        modest-init.c \
        modest-init.h \
        modest-local-folder-info.c \
-       modest-local-folder-info.h \
        modest-mail-operation-queue.c \
        modest-mail-operation-queue.h \
        modest-mail-operation.c \
@@ -109,6 +111,8 @@ libmodest_la_SOURCES=\
        modest-plugin.c \
        modest-plugin-factory.c \
        modest-plugin-factory.h \
+       modest-presets.c \
+       modest-presets.h \
        modest-progress-object.c \
        modest-progress-object.h \
        modest-protocol.c \
@@ -128,7 +132,6 @@ libmodest_la_SOURCES=\
        modest-tny-account.c \
        modest-tny-account.h \
        modest-tny-folder.c \
-       modest-tny-folder.h \
        modest-tny-local-folders-account.c \
        modest-tny-mime-part.c \
        modest-tny-mime-part.h \
@@ -144,6 +147,8 @@ libmodest_la_SOURCES=\
        modest-transport-account-decorator.h \
        modest-stream-text-to-html.c \
        modest-stream-text-to-html.h \
+       modest-stream-html-to-text.c \
+       modest-stream-html-to-text.h \
        modest-ui-actions.c \
        modest-ui-actions.h \
        modest-ui-dimming-manager.c \
@@ -172,10 +177,11 @@ libmodest_la_LIBADD =                                             \
        $(MODEST_HILDON_HELP_LIBS)                      \
        $(MODEST_HILDON_NOTIFY_LIBS)                    \
        $(MODEST_OGS_LIBS)                              \
+       $(MODEST_LIBTIME_LIBS)                          \
        ${easysetupmaybe} \
        widgets/libmodest-widgets.la                    \
        $(MODEST_TOOLKIT_DIR)/libmodest-ui.la
-libmodest_la_LDFLAGS = -rdynamic -no-undefined -Wl,--version-script=export.map
+libmodest_la_LDFLAGS = -rdynamic -no-undefined
 
 if MODEST_HAVE_DBUS_API
 libmodest_la_LIBADD += dbus_api/libmodest-dbus-api.la
@@ -191,7 +197,9 @@ modest_DEPENDENCIES = \
        libmodest.la
 
 modest_CFLAGS = $(MAEMO_LAUNCHER_CFLAGS)
+modest_UNWANTED = -export-dynamic -Wl,--export-dynamic
 modest_LDADD = \
+       $(filter-out $(modest_UNWANTED), \
        $(MAEMO_LAUNCHER_LIBS)                          \
        $(MODEST_GSTUFF_LIBS)                           \
        $(MODEST_MOZEMBED_LIBS)                         \
@@ -200,17 +208,30 @@ modest_LDADD = \
        $(MODEST_HILDON_HELP_LIBS)                      \
        $(MODEST_HILDON_NOTIFY_LIBS)                    \
        $(MODEST_OGS_LIBS)                              \
+       $(MODEST_LIBTIME_LIBS)                          \
        ${easysetupmaybe}                               \
-       libmodest.la
+       libmodest.la)
 
-modest_LDFLAGS = -rdynamic -no-undefined -Wl,--version-script=export.map
+modest_LDFLAGS = $(MAEMO_LAUNCHER_MODEST_LDFLAGS) -Wl,--version-script=export.map
 
 # modest_UNWANTED = -export-dynamic -Wl,--export-dynamic
 
 
-EXTRA_DIST=modest-marshal.list
+# mcc_mapping may be provided by the operator-wizard-settings package:
+# the one here is a copy, as that package is not available in chinook
+MMC_MAPPING_FILE=mcc_mapping
+mmccmappingdir=$(datadir)/modest/provider-data
+mmccmapping_DATA = $(MMC_MAPPING_FILE)
+
+PROVIDER_DATA_FILE=fallback-provider-data.keyfile
+providerdatadir=$(datadir)/modest/provider-data
+providerdata_DATA = $(PROVIDER_DATA_FILE)
+
+EXTRA_DIST=modest-marshal.list \
+       $(MMC_MAPPING_FILE) \
+       $(PROVIDER_DATA_FILE)
 
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = modest-plugin-1.0.pc
 
-DISTCLEANFILES = $(pkgconfig_DATA)
\ No newline at end of file
+DISTCLEANFILES = $(pkgconfig_DATA)