* some changes for modest-ui-account-setup in modest.glade, mostly widget names
[modest] / src / Makefile.am
index 931b4db..81e5435 100644 (file)
@@ -7,7 +7,18 @@ INCLUDES=\
        $(MODEST_GSTUFF_CFLAGS)\
        $(MODEST_LIBTINYMAIL_GNOME_DESKTOP_CFLAGS) \
        $(MODEST_LIBTINYMAIL_MAEMO_CFLAGS) \
-       -DPREFIX=\"@prefix@\"
+       -I$(MODEST_UI_DIR) -Wall\
+       -DPREFIX=\"@prefix@\" \
+       -Wall
+
+BUILT_SOURCES = modest-marshal.c modest-marshal.h
+
+modest-marshal.c: marshall.list
+       glib-genmarshal --body --prefix=modest_marshal < marshall.list > modest-marshal.c
+       
+modest-marshal.h: marshall.list
+       glib-genmarshal --header --prefix=modest_marshal < marshall.list > modest-marshal.h
+
 
 bin_PROGRAMS=\
        modest
@@ -25,8 +36,12 @@ modest_SOURCES=\
        modest-account-mgr.c\
        modest-window-mgr.h\
        modest-window-mgr.c\
+       modest-icon-factory.c\
+       modest-icon-factory.h\
        modest-tny-account-store.h\
        modest-tny-account-store.c\
+       modest-tny-attachment.h\
+       modest-tny-attachment.c\
        modest-tny-folder-tree-view.h\
        modest-tny-folder-tree-view.c\
        modest-tny-header-tree-view.h\
@@ -44,7 +59,15 @@ modest_SOURCES=\
        modest-tny-stream-gtkhtml.c\
        modest-tny-transport-actions.c\
        modest-tny-transport-actions.h\
-       modest-ui.h
+       modest-tny-store-actions.c\
+       modest-tny-store-actions.h\
+       modest-editor-window.c\
+       modest-editor-window.h\
+       modest-viewer-window.c\
+       modest-viewer-window.h\
+       modest-ui.h \
+       modest-marshal.c \
+       modest-marshal.h
 
 modest_LDADD = \
        $(MODEST_GSTUFF_LIBS) \