Fix modest_tny_msg_header_get_all_recipients_list (in case from is empty)
[modest] / src / Makefile.am
index 8144eb6..b720850 100644 (file)
@@ -2,25 +2,26 @@
 # Makefile.am
 # Time-stamp: <2008-01-06 10:18:49 (djcb)>
 
-SUBDIRS= $(MODEST_PLATFORM) widgets $(dbus_api)
-
-DIST_SUBDIRS = widgets gnome maemo dbus_api
+SUBDIRS= $(MODEST_TOOLKIT_DIR) widgets $(dbus_api)
+DIST_SUBDIRS = widgets gnome maemo hildon2 dbus_api
 
 INCLUDES=\
        $(MODEST_GSTUFF_CFLAGS)                                 \
        $(MODEST_PLATFORM_CFLAGS)                               \
-       $(MODEST_HILDON_WIDGETS_CFLAGS)                         \
+       $(MODEST_TOOLKIT_CFLAGS)                                \
+       $(MODEST_PLUGIN_DEFINES)                                \
        $(MODEST_OGS_CFLAGS)                                    \
        $(MODEST_HILDON_HELP_CFLAGS)                            \
        $(MODEST_LIBCONIC_CFLAGS)                               \
        $(MODEST_HILDON_NOTIFY_CFLAGS)                          \
        $(MODEST_MOZEMBED_CFLAGS)                               \
-       -fPIC \
-       -I$(MODEST_PLATFORM)                                    \
+       -fPIC                                                   \
+       -I$(MODEST_TOOLKIT_DIR)                                 \
        -DPREFIX=\"@prefix@\"                                   \
        -DMAEMO_CHANGES                                         \
        -DMODEST_LOCALEDIR=\"$(MODEST_LOCALEDIR)\"              \
        -DMODEST_PLATFORM=\"$(MODEST_PLATFORM)\"                \
+       -DMODEST_TOOLKIT=\"$(MODEST_TOOLKIT)\"          \
        -DPIXMAP_PREFIX=\"${datadir}/pixmaps/modest/\"          \
        -DMODEST_UIDIR=\"$(datadir)/modest/ui/\"                \
        -DMODEST_MAILPLUGINDIR=\"$(libdir)/modest/mail-plugins\"
@@ -38,10 +39,6 @@ noinst_LTLIBRARIES = libmodest.la
 bin_PROGRAMS=\
        modest
 
-to_remove=\
-       modest-testplugin-protocol.c \
-       modest-testplugin-protocol.h
-
 #
 # NOTE: $(addressbook) will be modest-addressbook-dummy.c
 # if no real addressbook has been defined (configure.ac)
@@ -54,14 +51,23 @@ modest_public_headers = \
        modest-account-settings.h \
        modest-cache-mgr.h \
        modest-conf.h \
+       modest-defs.h \
+       modest-local-folder-info.h \
+       modest-mail-operation.h \
+       modest-mail-operation-queue.h \
        modest-pair.h \
        modest-platform.h \
        modest-plugin.h \
+       modest-plugin-ui-actions.h \
        modest-protocol.h \
        modest-protocol-registry.h \
        modest-server-account-settings.h \
+       modest-signal-mgr.h \
+       modest-text-utils.h \
        modest-tny-account-store.h \
+       modest-tny-folder.h \
        modest-tny-local-folders-account.h \
+       modest-tny-send-queue.h \
        modest-utils.h
 
 libmodest_la_SOURCES=\
@@ -76,8 +82,10 @@ libmodest_la_SOURCES=\
        modest-conf.c \
        modest-count-stream.c \
        modest-count-stream.h \
+       modest-datetime-formatter.c \
+       modest-datetime-formatter.h \
        modest-debug.h \
-       modest-defs.h \
+       modest-defs.c \
        modest-dimming-rule.c \
        modest-dimming-rule.h \
        modest-dimming-rules-group.c \
@@ -90,7 +98,6 @@ libmodest_la_SOURCES=\
        modest-init.c \
        modest-init.h \
        modest-local-folder-info.c \
-       modest-local-folder-info.h \
        modest-mail-operation-queue.c \
        modest-mail-operation-queue.h \
        modest-mail-operation.c \
@@ -104,6 +111,8 @@ libmodest_la_SOURCES=\
        modest-plugin.c \
        modest-plugin-factory.c \
        modest-plugin-factory.h \
+       modest-presets.c \
+       modest-presets.h \
        modest-progress-object.c \
        modest-progress-object.h \
        modest-protocol.c \
@@ -119,12 +128,10 @@ libmodest_la_SOURCES=\
        modest-singletons.h \
        modest-server-account-settings.c \
        modest-text-utils.c \
-       modest-text-utils.h \
        modest-tny-account-store.c \
        modest-tny-account.c \
        modest-tny-account.h \
        modest-tny-folder.c \
-       modest-tny-folder.h \
        modest-tny-local-folders-account.c \
        modest-tny-mime-part.c \
        modest-tny-mime-part.h \
@@ -155,7 +162,7 @@ libmodest_la_SOURCES=\
 
 if MODEST_USE_DUMMY_ADDRESS_BOOK
 libmodest_la_SOURCES += modest-address-book-dummy.c
-endif 
+endif
 
 
 libmodest_la_CFLAGS  = $(MAEMO_LAUNCHER_CFLAGS)
@@ -164,14 +171,15 @@ libmodest_la_LIBADD =                                             \
        $(MODEST_GSTUFF_LIBS)                           \
        $(MODEST_MOZEMBED_LIBS)                         \
        $(MODEST_PLATFORM_LIBS)                         \
-       $(MODEST_HILDON_WIDGETS_LIBS)                   \
+       $(MODEST_TOOLKIT_LIBS)                  \
        $(MODEST_HILDON_HELP_LIBS)                      \
        $(MODEST_HILDON_NOTIFY_LIBS)                    \
        $(MODEST_OGS_LIBS)                              \
+       $(MODEST_LIBTIME_LIBS)                          \
        ${easysetupmaybe} \
        widgets/libmodest-widgets.la                    \
-       $(MODEST_PLATFORM)/libmodest-ui.la              
-libmodest_la_LDFLAGS = -rdynamic -export-dynamic -no-undefined -Wl,--version-script=export.map
+       $(MODEST_TOOLKIT_DIR)/libmodest-ui.la
+libmodest_la_LDFLAGS = -rdynamic -no-undefined
 
 if MODEST_HAVE_DBUS_API
 libmodest_la_LIBADD += dbus_api/libmodest-dbus-api.la
@@ -187,24 +195,39 @@ modest_DEPENDENCIES = \
        libmodest.la
 
 modest_CFLAGS = $(MAEMO_LAUNCHER_CFLAGS)
+modest_UNWANTED = -export-dynamic -Wl,--export-dynamic
 modest_LDADD = \
+       $(filter-out $(modest_UNWANTED), \
        $(MAEMO_LAUNCHER_LIBS)                          \
        $(MODEST_GSTUFF_LIBS)                           \
        $(MODEST_MOZEMBED_LIBS)                         \
        $(MODEST_PLATFORM_LIBS)                         \
-       $(MODEST_HILDON_WIDGETS_LIBS)                   \
+       $(MODEST_TOOLKIT_LIBS)                  \
        $(MODEST_HILDON_HELP_LIBS)                      \
        $(MODEST_HILDON_NOTIFY_LIBS)                    \
        $(MODEST_OGS_LIBS)                              \
+       $(MODEST_LIBTIME_LIBS)                          \
        ${easysetupmaybe}                               \
-       libmodest.la
+       libmodest.la)
 
-modest_LDFLAGS = -rdynamic -export-dynamic -no-undefined -Wl,--version-script=export.map
+modest_LDFLAGS = $(MAEMO_LAUNCHER_MODEST_LDFLAGS) -Wl,--version-script=export.map
 
 # modest_UNWANTED = -export-dynamic -Wl,--export-dynamic
 
 
-EXTRA_DIST=modest-marshal.list
+# mcc_mapping may be provided by the operator-wizard-settings package:
+# the one here is a copy, as that package is not available in chinook
+MMC_MAPPING_FILE=mcc_mapping
+mmccmappingdir=$(datadir)/modest/provider-data
+mmccmapping_DATA = $(MMC_MAPPING_FILE)
+
+PROVIDER_DATA_FILE=fallback-provider-data.keyfile
+providerdatadir=$(datadir)/modest/provider-data
+providerdata_DATA = $(PROVIDER_DATA_FILE)
+
+EXTRA_DIST=modest-marshal.list \
+       $(MMC_MAPPING_FILE) \
+       $(PROVIDER_DATA_FILE)
 
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = modest-plugin-1.0.pc