Modified webpage: now tinymail repository is in gitorious.
[modest] / src / gtk / Makefile.am
index 5f56d63..78142aa 100644 (file)
@@ -1,47 +1,59 @@
-#
-# Makefile.am
-# Time-stamp: <2006-07-29 20:47:31 (djcb)>
-#
-#
-# use Automake 'trick' ==> convenience static libraries, which
-# won't be installed, just for linking
-#
+# Copyright (c) 2009 Nokia Corporation
+# All rights reserved.
+# 
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+# 
+# * Redistributions of source code must retain the above copyright
+#   notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+#   notice, this list of conditions and the following disclaimer in the
+#   documentation and/or other materials provided with the distribution.
+# * Neither the name of the Nokia Corporation nor the names of its
+#   contributors may be used to endorse or promote products derived from
+#   this software without specific prior written permission.
+# 
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS
+# IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+# TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+# PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
+# OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 INCLUDES=\
        $(MODEST_GSTUFF_CFLAGS) \
-       $(MODEST_LIBTINYMAIL_GNOME_DESKTOP_CFLAGS) \
-       -I ${top_srcdir}/src/widgets  \
+       $(MODEST_PLATFORM_CFLAGS) \
+       $(MODEST_TOOLKIT_CFLAGS) \
+       $(MODEST_PLUGIN_DEFINES) \
        -I ${top_srcdir}/src  \
+       -I ${top_srcdir}/src/widgets  \
        -DPREFIX=\"@prefix@\" \
-       -DPIXMAP_PREFIX=\"${datadir}/pixmaps/modest/\" \
-       -DMODEST_UIDIR=\""$(datadir)/modest/ui/"\" \
        -Wall
 
 noinst_LTLIBRARIES=\
        libmodest-ui.la
 
-PIXMAP_FILES=\
-       pixmaps/*.png \
-       pixmaps/*.svg
-
-libmodest_ui_la_SOURCES=              \
-       modest-main-window.h          \
-       modest-main-window.c          \
-       modest-account-view-window.c  \
-       modest-account-view-window.h  \
-       modest-account-assistant.c    \
-       modest-account-assistant.h    \
-       modest-edit-msg-window.c      \
-       modest-edit-msg-window.h      \
-       modest-transport-widget.c     \
-       modest-transport-widget.h     \
-       modest-store-widget.c         \
-       modest-store-widget.h
+libmodest_ui_la_SOURCES= \
+       modest-icon-names.h \
+       modest-gtk-window-mgr.h modest-gtk-window-mgr.c \
+       modest-platform.c \
+       modest-shell.h modest-shell.c \
+       modest-shell-banner.h modest-shell-banner.c \
+       modest-shell-window.h modest-shell-window.c
 
-LDADD = \
+libmodest_ui_la_LIBADD = \
        $(MODEST_GSTUFF_LIBS) \
-       $(MODEST_LIBTINYMAIL_GNOME_DESKTOP_LIBS)
+       $(MODEST_ABOOK_LIBS) \
+       $(MODEST_PLATFORM_LIBS) \
+       $(MODEST_TOOLKIT_LIBS) \
+       $(MODEST_WPEDITOR_LIBS)
 
-EXTRA_DIST=pixmaps/*
+desktopentry_DATA   = modest.desktop
 
-pixmapdir = $(datadir)/pixmaps/modest
-pixmap_DATA = $(PIXMAP_FILES)
+EXTRA_DIST=\
+       $(desktopentry_DATA)