Modified webpage: now tinymail repository is in gitorious.
[modest] / src / gtk / Makefile.am
index 7ee144f..78142aa 100644 (file)
@@ -31,11 +31,20 @@ INCLUDES=\
        $(MODEST_TOOLKIT_CFLAGS) \
        $(MODEST_PLUGIN_DEFINES) \
        -I ${top_srcdir}/src  \
+       -I ${top_srcdir}/src/widgets  \
        -DPREFIX=\"@prefix@\" \
        -Wall
 
+noinst_LTLIBRARIES=\
+       libmodest-ui.la
+
 libmodest_ui_la_SOURCES= \
-       modest-icon-names.h
+       modest-icon-names.h \
+       modest-gtk-window-mgr.h modest-gtk-window-mgr.c \
+       modest-platform.c \
+       modest-shell.h modest-shell.c \
+       modest-shell-banner.h modest-shell-banner.c \
+       modest-shell-window.h modest-shell-window.c
 
 libmodest_ui_la_LIBADD = \
        $(MODEST_GSTUFF_LIBS) \
@@ -44,3 +53,7 @@ libmodest_ui_la_LIBADD = \
        $(MODEST_TOOLKIT_LIBS) \
        $(MODEST_WPEDITOR_LIBS)
 
+desktopentry_DATA   = modest.desktop
+
+EXTRA_DIST=\
+       $(desktopentry_DATA)