* let the dbus-invoked msgs use the same uids as other messages,
[modest] / src / widgets / Makefile.am
index c35bc20..a8fdc3b 100644 (file)
@@ -1,15 +1,14 @@
 #
 # Makefile.am
-# Time-stamp: <2007-02-10 14:48:38 (djcb)>
+# Time-stamp: <2007-06-23 15:40:04 (djcb)>
 
 INCLUDES=\
        $(MODEST_GSTUFF_CFLAGS) \
-       $(MODEST_LIBTINYMAIL_GNOME_DESKTOP_CFLAGS) \
-       $(MODEST_LIBTINYMAIL_MAEMO_CFLAGS) \
+       $(MODEST_PLATFORM_CFLAGS) \
+       $(MODEST_HILDON_WIDGETS_CFLAGS) \
        -I ${top_srcdir}/src/$(MODEST_PLATFORM) \
        -I ${top_srcdir}/src \
        -DPREFIX=\"@prefix@\" \
-       -DMODEST_PLATFORM_ID=$(MODEST_PLATFORM_ID) \
        -DPIXMAP_PREFIX=\"${datadir}/pixmaps/modest/\" \
        -Wall
 
@@ -28,6 +27,12 @@ libmodest_widgets_la_SOURCES=          \
        modest-combo-box.h             \
        modest-folder-view.c           \
        modest-folder-view.h           \
+       modest-global-settings-dialog.c \
+       modest-global-settings-dialog.h \
+       modest-hbox-cell-renderer.c    \
+       modest-hbox-cell-renderer.h    \
+       modest-vbox-cell-renderer.c    \
+       modest-vbox-cell-renderer.h    \
        modest-header-view-render.c    \
        modest-header-view.c           \
        modest-header-view.h           \
@@ -41,20 +46,21 @@ libmodest_widgets_la_SOURCES=          \
        modest-msg-view-window.h       \
        modest-msg-view.c              \
        modest-msg-view.h              \
-       modest-msg-view-details-dialog.c \
-       modest-msg-view-details-dialog.h \
+       modest-details-dialog.c        \
+       modest-details-dialog.h        \
        modest-recpt-editor.c          \
        modest-recpt-editor.h          \
        modest-recpt-view.c            \
        modest-recpt-view.h            \
-       modest-retrieve-combo-box.h \
-       modest-retrieve-combo-box.c \
+       modest-retrieve-combo-box.h    \
+       modest-retrieve-combo-box.c    \
        modest-scroll-text.c           \
        modest-scroll-text.h           \
        modest-serversecurity-combo-box.h modest-serversecurity-combo-box.c \
        modest-secureauth-combo-box.h modest-secureauth-combo-box.c \
        modest-tny-stream-gtkhtml.c    \
        modest-tny-stream-gtkhtml.h    \
+       modest-ui-constants.h \
        modest-validating-entry.h modest-validating-entry.c \
        modest-window.c                \
        modest-window.h                \
@@ -63,5 +69,5 @@ libmodest_widgets_la_SOURCES=          \
 
 LDADD = \
        $(MODEST_GSTUFF_LIBS)                           \
-       $(MODEST_LIBTINYMAIL_GNOME_DESKTOP_LIBS)        \
-       $(MODEST_LIBTINYMAIL_MAEMO_LIBS)                
+       $(MODEST_PLATFORM_LIBS)                         \
+       $(MODEST_HILDON_WIDGETS_LIBS)