* Added missing files
[modest] / tests / Makefile.am
index 5b62ec7..bc4b7a5 100644 (file)
@@ -9,19 +9,17 @@ TESTS_ENVIRONMENT       = top_builddir=$(top_builddir)  \
                          CK_VERBOSITY=verbose
 
 TESTS                   =                           \
-                       check_modest-presets        \
                         check_folder-xfer           \
                        check_text-utils            \
                        check_modest-conf           \
-                        check_update-account        \
+                       check_update_account        \
                        check_account-mgr           
 
 noinst_PROGRAMS=                                   \
                        check_folder-xfer           \
-                       check_update-account        \
                        check_modest-conf           \
                        check_text-utils            \
-                       check_modest-presets        \
+                       check_update_account        \
                        check_account-mgr
 
 INCLUDES=\
@@ -41,10 +39,12 @@ objects=\
         ${top_srcdir}/src/$(MODEST_PLATFORM)/libmodest-ui.la \
         ${top_srcdir}/src/widgets/libmodest-widgets.la \
         ${top_srcdir}/src/modest-account-mgr.o \
+        ${top_srcdir}/src/modest-account-mgr-helpers.o \
+        ${top_srcdir}/src/modest-account-mgr-priv.o \
         ${top_srcdir}/src/modest-conf.o \
+        ${top_srcdir}/src/modest-cache-mgr.o \
         ${top_srcdir}/src/modest-protocol-info.o \
         ${top_srcdir}/src/modest-formatter.o \
-        ${top_srcdir}/src/modest-presets.o \
         ${top_srcdir}/src/modest-pair.o \
         ${top_srcdir}/src/modest-marshal.o \
         ${top_srcdir}/src/modest-tny-account-store.o \
@@ -52,6 +52,7 @@ objects=\
         ${top_srcdir}/src/modest-mail-operation-queue.o \
         ${top_srcdir}/src/modest-mail-operation.o \
         ${top_srcdir}/src/modest-tny-msg-actions.o \
+        ${top_srcdir}/src/modest-local-folder-info.o \
         ${top_srcdir}/src/modest-tny-folder.o \
         ${top_srcdir}/src/modest-text-utils.o
 
@@ -72,10 +73,6 @@ check_text_utils_SOURCES=\
        check_text-utils.c
 check_text_utils_LDADD = $(objects)
 
-check_modest_presets_SOURCES=\
-       check_modest-presets.c
-check_modest_presets_LDADD = $(objects)
-
 check_account_mgr_SOURCES=\
        check_account-mgr.c
 check_account_mgr_LDADD = $(objects)