* Added missing files
[modest] / tests / Makefile.am
index 813d483..bc4b7a5 100644 (file)
@@ -9,17 +9,17 @@ TESTS_ENVIRONMENT       = top_builddir=$(top_builddir)  \
                          CK_VERBOSITY=verbose
 
 TESTS                   =                           \
-                       check_modest-presets        \
                         check_folder-xfer           \
                        check_text-utils            \
                        check_modest-conf           \
+                       check_update_account        \
                        check_account-mgr           
 
 noinst_PROGRAMS=                                   \
                        check_folder-xfer           \
                        check_modest-conf           \
                        check_text-utils            \
-                       check_modest-presets        \
+                       check_update_account        \
                        check_account-mgr
 
 INCLUDES=\
@@ -39,10 +39,12 @@ objects=\
         ${top_srcdir}/src/$(MODEST_PLATFORM)/libmodest-ui.la \
         ${top_srcdir}/src/widgets/libmodest-widgets.la \
         ${top_srcdir}/src/modest-account-mgr.o \
+        ${top_srcdir}/src/modest-account-mgr-helpers.o \
+        ${top_srcdir}/src/modest-account-mgr-priv.o \
         ${top_srcdir}/src/modest-conf.o \
+        ${top_srcdir}/src/modest-cache-mgr.o \
         ${top_srcdir}/src/modest-protocol-info.o \
         ${top_srcdir}/src/modest-formatter.o \
-        ${top_srcdir}/src/modest-presets.o \
         ${top_srcdir}/src/modest-pair.o \
         ${top_srcdir}/src/modest-marshal.o \
         ${top_srcdir}/src/modest-tny-account-store.o \
@@ -71,10 +73,6 @@ check_text_utils_SOURCES=\
        check_text-utils.c
 check_text_utils_LDADD = $(objects)
 
-check_modest_presets_SOURCES=\
-       check_modest-presets.c
-check_modest_presets_LDADD = $(objects)
-
 check_account_mgr_SOURCES=\
        check_account-mgr.c
 check_account_mgr_LDADD = $(objects)