Added test for OpenEditAccountsDialog Dbus method
[modest] / tests / dbus_api / Makefile.am
index bc1dd67..061ac5c 100644 (file)
@@ -1,5 +1,6 @@
 INCLUDES=\
        @CHECK_CFLAGS@ \
+       $(LIBMODEST_DBUS_CLIENT_CFLAGS) \
        $(MODEST_GSTUFF_CFLAGS)\
        $(MODEST_LIBTINYMAIL_GNOME_DESKTOP_CFLAGS) \
        $(MODEST_LIBTINYMAIL_MAEMO_CFLAGS) \
@@ -11,6 +12,7 @@ INCLUDES=\
 
 objects=\
        @CHECK_LIBS@ \
+       $(LIBMODEST_DBUS_CLIENT_LIBS)
        $(MODEST_GSTUFF_LIBS) \
        $(MODEST_PLATFORM_LIBS) \
        $(MODEST_TOOLKIT_LIBS) \
@@ -28,7 +30,9 @@ noinst_PROGRAMS = \
        test_open_default_inbox \
        test_get_folders \
        test_top_application \
-       test_update_account
+       test_update_account \
+       test_open_account \
+       test_open_edit_accounts_dialog
 
 test_mail_to_SOURCES = test_mail_to.c
 test_mail_to_LDADD = $(objects)
@@ -56,3 +60,9 @@ test_top_application_LDADD = $(objects)
 
 test_update_account_SOURCES = test_update_account.c
 test_update_account_LDADD = $(objects)
+
+test_open_account_SOURCES = test_open_account.c
+test_open_account_LDADD = $(objects)
+
+test_open_edit_accounts_dialog_SOURCES = test_open_edit_accounts_dialog.c
+test_open_edit_accounts_dialog_LDADD = $(objects)