2007-06-12 Murray Cumming <murrayc@murrayc.com>
[modest] / tests / dbus_api / Makefile.am
index d827648..27805a7 100644 (file)
@@ -5,6 +5,7 @@ INCLUDES=\
        $(MODEST_LIBTINYMAIL_MAEMO_CFLAGS) \
        -I$(MODEST_PLATFORM) \
        -I${top_srcdir}/src \
+       -I$(top_srcdir) \
        -DPREFIX=\"@prefix@\" \
        -DMODESTLOCALEDIR=\""$(modestlocaledir)"\"
        
@@ -12,10 +13,34 @@ objects=\
        @CHECK_LIBS@ \
        $(MODEST_GSTUFF_LIBS) \
         $(MODEST_LIBTINYMAIL_GNOME_DESKTOP_LIBS) \
-        $(MODEST_LIBTINYMAIL_MAEMO_LIBS)
+        $(MODEST_LIBTINYMAIL_MAEMO_LIBS) \
+        ${top_srcdir}/libmodest-dbus-client/libmodest-dbus-client-1.0.la
         
-noinst_PROGRAMS = test_hello
+noinst_PROGRAMS = test_send_mail      \
+                 test_mail_to        \
+                 test_open_message   \
+                 test_search         \
+                 test_delete_message \
+                 test_compose_mail \
+                 test_open_default_inbox
 
-test_hello_SOURCES = test_hello.c
-test_hello_LDADD = $(objects)
+test_send_mail_SOURCES = test_send_mail.c
+test_send_mail_LDADD = $(objects)
 
+test_mail_to_SOURCES = test_mail_to.c
+test_mail_to_LDADD = $(objects)
+
+test_open_message_SOURCES = test_open_message.c
+test_open_message_LDADD = $(objects)
+
+test_compose_mail_SOURCES = test_compose_mail.c
+test_compose_mail_LDADD = $(objects)
+
+test_search_SOURCES = test_search.c
+test_search_LDADD = $(objects)
+
+test_delete_message_SOURCES = test_delete_message.c
+test_delete_message_LDADD = $(objects)
+
+test_open_default_inbox_SOURCES = test_open_default_inbox.c
+test_open_default_inbox_LDADD = $(objects)